Please help with audio problem - diyAudio
Go Back   Home > Forums > Source & Line > Digital Source

Digital Source Digital Players and Recorders: CD , SACD , Tape, Memory Card, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 16th January 2009, 07:02 PM   #1
rtate is offline rtate  Canada
diyAudio Member
 
Join Date: Jan 2002
Location: Burlington, Ontario, Canada
Default Please help with audio problem

I am just about finished modding my denon dvd2900 and all was going great..Now I have a problem on the right channel audio.

The music is there but very distorted and very bass heavy.It is also much louder than the left channel which is fine.I have done all the usual things like swapping IC cables switching channels etc..

I have replaced all opamps and signal path resistors as well as all the coupling capacitors around the opamps with polystyrene.

The player was working so I am confident that in instalation was correct.

I have checked all my solder connections and reflowed most.
I think that it is a component problem but I was wondering if my symptoms point to something specific... ie. capacitor, resistor etc..

Any suggestions would be greatly appreciated!!!
  Reply With Quote
Old 16th January 2009, 08:31 PM   #2
guytou is offline guytou  France
diyAudio Member
 
Join Date: Mar 2005
Location: marseille
hi rtate ,

maybe you could have a bad link at the feedback chain of opamps.
  Reply With Quote
Old 16th January 2009, 08:34 PM   #3
rtate is offline rtate  Canada
diyAudio Member
 
Join Date: Jan 2002
Location: Burlington, Ontario, Canada
Thanks for the reply guytou!!

What would I look for to check the feedback links??
  Reply With Quote
Old 16th January 2009, 09:29 PM   #4
guytou is offline guytou  France
diyAudio Member
 
Join Date: Mar 2005
Location: marseille
i am thinking on all components between in and out of opamps. Usually there are feedbacks resistors between in and out
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
car audio problem mike49504 Car Audio 12 12th April 2007 10:59 PM
Kole Audio Amp Problem...HELP dozan1 Car Audio 4 14th February 2007 06:51 AM
Problem w/Clipping new 2 car audio need help bmxkris Car Audio 2 4th April 2005 05:27 PM
CD audio channel problem gmonno Digital Source 0 5th July 2004 01:07 PM
problem with my audio alchemy DDE 3.0 dexter Digital Source 0 23rd February 2004 03:39 AM


New To Site? Need Help?

All times are GMT. The time now is 02:30 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2