Marantz CD63 KI SIG, Error 12, Sled Error problem - diyAudio
Go Back   Home > Forums > Source & Line > Digital Source

Digital Source Digital Players and Recorders: CD , SACD , Tape, Memory Card, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 9th November 2008, 02:43 PM   #1
sisik is offline sisik  England
diyAudio Member
 
Join Date: Nov 2008
Default Marantz CD63 KI SIG, Error 12, Sled Error problem

Hello everyone, I am new to this site and wonder if anyone can help with my Marantz CD problem? My CD player went wrong initially about 2 years ago when it started skipping every now and again, cleaning did not help. Since then I have installed 2 new optical drives a Philips VAM 1202/12. They both worked for about 6 months each before the problem started again, and then would not register CD's at all!. So again I installed another new Philips optical drive to no avail! Following the diagnostic instructions it comes up with Error 12 sled error. I tried putting the whole transport unit into my other basic CD 63 and it works perfectly! What could be wrong with the KI player? is it something on the PCB? How can I check? I have thought about replacing the PCB on the KI player with the basic CD 63 players PCB? Any thoughts, they both look the same essentially. I find the KI player a much more enjoyable listen.
  Reply With Quote
Old 9th November 2008, 03:12 PM   #2
poynton is offline poynton  United Kingdom
diyAudio Member
 
poynton's Avatar
 
Join Date: Mar 2005
Location: A life on the ocean waves when I'm not at home in N. Wales (but I'm not Welsh so no sheep jokes!)
Where are you getting the replacement mechanisms from?

Many (most) of the "chinese" ones on the market either are faulty out of the box or fail like you describe !

Andy
__________________
If it ain't broke, break it !! Then fix it again. It's called DIY !
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Marantz CD 63 'Radial error' dingzie Digital Source 2 16th March 2007 07:01 PM
Marantz CD10 TOC error trellis Digital Source 6 23rd May 2006 04:03 PM
Marantz 63 - Error 12 eitank Digital Source 3 19th September 2005 09:05 PM
CD63 occassional radial error Im Sparticus Digital Source 3 27th July 2005 07:57 AM
Whats worse, 1db error in response curve or a phase error of 6? primalsea Multi-Way 5 13th May 2003 01:24 AM


New To Site? Need Help?

All times are GMT. The time now is 04:27 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2