Go Back   Home > Forums > Source & Line > Digital Source

Digital Source Digital Players and Recorders: CD , SACD , Tape, Memory Card, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 31st August 2008, 07:42 AM   #1
Skorpio is offline Skorpio  Denmark
diyAudio Member
 
Join Date: Mar 2004
Location: Denmark
Default Rotel RCD-971 tray problem...

I have a problem with this machine:

When loading a disc from tray, a moter noise is on for a few seconds and then the tray opens again...

It seems that the laser unit do not clamp onto the disc...the tray is opened before this I guess?

Anybody with a input for solution?
  Reply With Quote
Old 31st August 2008, 05:32 PM   #2
Mooly is online now Mooly  United Kingdom
diyAudio Moderator
 
Mooly's Avatar
 
Join Date: Sep 2007
Does it have belt ? That sounds favourite. Anything like this.
Attached Images
File Type: jpg loader.jpg (31.5 KB, 142 views)
  Reply With Quote
Old 31st August 2008, 05:56 PM   #3
Skorpio is offline Skorpio  Denmark
diyAudio Member
 
Join Date: Mar 2004
Location: Denmark
The transport is SONY KSL-2130 and it does have a belt....
  Reply With Quote
Old 1st September 2008, 06:44 AM   #4
Mooly is online now Mooly  United Kingdom
diyAudio Moderator
 
Mooly's Avatar
 
Join Date: Sep 2007
Well !!!
  Reply With Quote
Old 1st September 2008, 07:11 PM   #5
Skorpio is offline Skorpio  Denmark
diyAudio Member
 
Join Date: Mar 2004
Location: Denmark
Default Loading problem

I have now looked closer to the problem, and I no longer think that the belt (driving the tray). The reason is that the tray is moving fine and quick in both directions. Also, you are not able to "help" it further in with your hand.

When looking closer at the loading I saw that the laser part didn't swing up. It moves upwards, but not enougt.

Removing the disc enables you to "help" the swing up with a gentle finger and then it is in position. I dont think it is a motor swinging the laser up?

Puting the disc in again a light pump on the buttom plate is enough to engage the laser to load and everything works fine....

  Reply With Quote
Old 2nd September 2008, 07:04 AM   #6
Mooly is online now Mooly  United Kingdom
diyAudio Moderator
 
Mooly's Avatar
 
Join Date: Sep 2007
Hi Skorpio,
It still really sounds like a belt problem to me. Can you see how the pickup sub chassis is driven. Can you hear the motor run after the drawer has closed, but it's not doing anything ?
It can't be much
When you open the tray is there much "power" to it. If you gently try and stop the tray as it comes out does it push against your finger or does the belt slip ?

Edit -- It can only be
1. The motor continues to run but doesn't raise the mech due to a slipping belt.

2. The motor stops as soon as the tray closes due to a problem such as a microswitch etc.

3. Does it use gears to lift the mech -- stripped teeth maybe.

4. It uses another motor/belt for the mech lift ?

  Reply With Quote
Old 2nd September 2008, 07:46 AM   #7
Skorpio is offline Skorpio  Denmark
diyAudio Member
 
Join Date: Mar 2004
Location: Denmark
Quote:
Originally posted by Mooly
Hi Skorpio,
It still really sounds like a belt problem to me. Can you see how the pickup sub chassis is driven. Can you hear the motor run after the drawer has closed, but it's not doing anything ?
It can't be much
When you open the tray is there much "power" to it. If you gently try and stop the tray as it comes out does it push against your finger or does the belt slip ?

Edit -- It can only be
1. The motor continues to run but doesn't raise the mech due to a slipping belt.

2. The motor stops as soon as the tray closes due to a problem such as a microswitch etc.

3. Does it use gears to lift the mech -- stripped teeth maybe.

4. It uses another motor/belt for the mech lift ?


Thank for helping....

4. I have lifted the complete assembly up and it seems the is a 3 motor possibly driving the laserpart?

The tray moves nicely in and out....the laser do not clamp up to meet disc, only half way...you hear a motor running. A finger can help the last bit and everything works nice. When taking disk out, no help needed.

I am woried about taking drive more apart as I read a thread where a guy warned about that with Sony drives because of alignment of mechanics?



  Reply With Quote
Old 2nd September 2008, 07:48 AM   #8
Skorpio is offline Skorpio  Denmark
diyAudio Member
 
Join Date: Mar 2004
Location: Denmark
There also might be some gears to lift laserpart, under the transport is a "black box" with a srew. Turning this screw moved the laser part up and down....like the motor perhaps shoud do?
  Reply With Quote
Old 2nd September 2008, 10:45 AM   #9
Mooly is online now Mooly  United Kingdom
diyAudio Moderator
 
Mooly's Avatar
 
Join Date: Sep 2007
Hi Skorpio,
Would have to see it really. I think you are going to have to pull it apart a bit more. You could post come pictures - not saying it would help but you never know.
Can you find the service manual anywhere ?
  Reply With Quote
Old 2nd September 2008, 01:55 PM   #10
Skorpio is offline Skorpio  Denmark
diyAudio Member
 
Join Date: Mar 2004
Location: Denmark
http://www.disconetto.dk/shop/laser-...ed-14351p.html

http://images.google.com/imgres?imgu...%3Dda%26sa%3DN

This should show laser unit assembly.....I am trying to get service manual at Rotel Support....
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
NAD C521 Tray Problem isticism Digital Source 6 18th February 2014 03:25 PM
CD960 tray problem... Skorpio Digital Source 8 17th July 2010 12:31 PM
Sony CDP-101 Tray Problem idealist Digital Source 3 11th August 2007 02:37 PM
cd80 with tray problem musicfreak Digital Source 0 10th July 2006 11:10 PM
CD tray problem!!! Anorgan Digital Source 2 28th February 2004 10:47 PM


New To Site? Need Help?

All times are GMT. The time now is 02:40 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2