diyAudio

diyAudio (http://www.diyaudio.com/forums/)
-   Digital Source (http://www.diyaudio.com/forums/digital-source/)
-   -   The Connection from the Sony CD decoder to DF1704 (http://www.diyaudio.com/forums/digital-source/12606-connection-sony-cd-decoder-df1704.html)

hatasa 18th March 2003 01:24 PM

The Connection from the Sony CD decoder to DF1704
 
Hi all,

I would like to know what is the setting on the DF1704 for the Sony CD decoder like CXD1130,1135.....?

16bit MSB Left?
18bit MSB Left?
20bit MSB Left? or 24bit MSB?

Or possible at I2S??

And about the output to PCM1704... what should the setting also?

24bit? 20bit...?

Thanks!

I deside to give the master clock to the DF1704 at 16.9344MHz

Jocko Homo 27th March 2003 01:52 PM

The Japanese scheme uses right-justified data, which means you have to pick the right word lengtth to get the levels correct. I forget which pins are connected which way......I have done it, but I forget right now.

You set the output for whatever DAC chip you are using, and what it wants to see. In this case......24 bits.

Of ocurse, if you had bought one of the PCBs I designed that does this..........

(Break out the spam song..........)

Jocko

hatasa 27th March 2003 02:31 PM

:bulb: Ohhh Thanks!

I must be try it asap!

That means all of the setting should be 24bits? Include the PCM1704?

:confused:

A 8 28th March 2003 12:59 PM

You set the DF1704 to 24 bits out and the PCM1704 to recieve 24 bits.

As Jocko Homo said the sony will output right jusified but you don't know the wordlength?
I guess you will have to test which is correct, start with 24 bits so that you know it works and then switch to lower bits until you hear heavy distortion on 0dB levels, then you'll know which one is correct.

Or just measure the analog output for a 0dB signal and make sure it is on spec.
Or if you have a oscilloscope, count the pulses within the wordclock.

hatasa 28th March 2003 01:57 PM

Thanks all for the help...

But I tired today! Fail.... I need to check for the Board which is it correct first!

The clock frequency is 16.9344MHz I also tried on 24.XXX but both have no sound. Completely slient! I think I should re-check again!

The soft mute pin should be connect +5V right? And I just leave the DEM pin alone... nothing connect to the RST also....

Opps! Need to recheck!:dead:

A 8 28th March 2003 02:10 PM

Have you set it in hw mode?

I think you need to use the same clock that originates the other streams or build your own and make sure ut runs the rest of the curcuits.

Jocko Homo 28th March 2003 02:27 PM

Se the filter input for 16-bits, as that is what all decoders put out. (There are only 16 bits on the CD to begin with.........)

The clock will be 16. whatever.......you can leave the mute and de-emp pins alone.

You should see data pulses on the 2 data out pins of the filter, but only when a disc is spinning.

If you don't have a 'scope.....................

Jocko

A 8 28th March 2003 02:36 PM

aaah a CD player:clown:


All times are GMT. The time now is 10:43 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio


Content Relevant URLs by vBSEO 3.3.2