Aliens in my CD67SE? - diyAudio
Go Back   Home > Forums > Source & Line > Digital Source

Digital Source Digital Players and Recorders: CD , SACD , Tape, Memory Card, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 27th February 2003, 12:30 PM   #1
diyAudio Member
 
ashok's Avatar
 
Join Date: Jun 2002
Location: 3RS
Default Aliens in my CD67SE?

Hi,
Ergo and others will remember me trying to fix my CD 67SEMkII mid 2002. Well as usual I spend a long time over these things because often they get solved given enough time. My 67 suddenly died as the disc stopped rotating. Ergo and others helped a lot but I could not find the actual reason. Today I pulled it apart and tried again. No eye pattern - no rotation. Though I get reverse rotation in service mode.
After several minutes I got fed up and started pressing the track change buttons randomly and rapidly. Suddenly the display showed the disk time. I pressed play and it started playing.
What gives ? Stuck button? If so they would not operate in service mode - they did.
I checked all supply voltages and they seem fine. The +5V at the transport shows 4.96V while it is 5.08V at the regulator. When the disc spins the voltage at the connector drops to 4.67V.
The eye pattern is supposed to have a dc bias of 2.5 V and be 1.7V peak to peak. I get 1 V dc and 0.9 volts peak to peak.
Ergo, can you guess what happened? So should I do something to prevent it from stopping again? Laser current to be increased?
Its pretty tough doing that because the pot is under the transport.
Thanks.
__________________
AM
  Reply With Quote
Old 6th March 2003, 01:33 PM   #2
ergo is offline ergo  Estonia
diyAudio Member
 
Join Date: Mar 2001
Location: Tallinn, Estonia
Seems to me you are just one lucky guy

As to what was wrong with the player, well it's really hard to tell. One reason for disc spinning backwards and player acting weird was no clock signal...

For CD67 it is impossible to adjust laser power it is automatic and done by TDA1307 (if I remember correctly).

I had a problem with my own player once that it didn't play CDR-s. It turned out that for some reason the TDA1307 (fixed gain device with gain of 1.7) did not have the gain needed for some reason. On scope it also showed some 0.7Vpp with CDR disc.... replacing the part cured the player..... If your's plays all the discs then leave it be, if not then I suggest try to replace TDA1307.

Ergo
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Questions for Marantz CD67SE kinycobain Digital Source 0 26th January 2006 01:22 PM
My Marantz cd67SE needs a warming up hanszl2001 Digital Source 0 1st April 2005 07:53 AM
Just a little recap on CD67se mods floatingkiwi Digital Source 3 26th January 2005 03:50 PM
new DAC to partner with my cd67se, your guidance plz Drew.J.K Digital Source 0 29th December 2004 07:36 PM
CD67SE mods - where do I go from here? dantwomey Digital Source 13 1st February 2004 02:21 AM


New To Site? Need Help?

All times are GMT. The time now is 06:39 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2