Please ! Help with Technics SL-PS770A - diyAudio
Go Back   Home > Forums > Source & Line > Digital Source

Digital Source Digital Players and Recorders: CD , SACD , Tape, Memory Card, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 30th June 2007, 10:14 PM   #1
diyAudio Member
 
Join Date: Jan 2007
Location: europe
Unhappy Please ! Help with Technics SL-PS770A

Hi there,


I can not find the mistake I did today while tweaking this reader.

I changed diodes for some BYV28-200 in order to connect some big (10 000F 50V) power caps. I did not connect yet the big caps.
Also changed many resistors and took care to put the good values, and some other chemi caps (voltage and value respected).

I checked several times but can't find where I got wrong, the reader refuses to start and I even don't get the "standby" red light.

EDIT HERE: Also replaced LM833 by AD8599 (2), OPA2277U (1) and the 4560 by an AD8620.

Would somebody give me a hand with the schematics, or better some pics of the top of the PCB ?

I would really appreciate to get this reader working again, it sounds pretty well.


Thanks a lot.
  Reply With Quote
Old 30th June 2007, 10:48 PM   #2
diyAudio Member
 
aparatusonitus's Avatar
 
Join Date: Jan 2004
Location: Split, Croatia
Mail me, and you can have a service manual right now
__________________
Non mai abbastanza...
  Reply With Quote
Old 1st July 2007, 12:17 PM   #3
diyAudio Member
 
Join Date: Jan 2007
Location: europe
email sent, thanks

EDIT: thanks for this fast sending.

It's a bit too complicated for me, would you please help me if I send some pictures ? It would be very kind.

I will do it at the end of next week If you agree do give me a hand.


Thanks again,


Charles.
  Reply With Quote
Old 1st July 2007, 12:58 PM   #4
diyAudio Member
 
aparatusonitus's Avatar
 
Join Date: Jan 2004
Location: Split, Croatia
I'll take a look, but I can't promise anything...but you will get a extra helping hand(s) from diy community all right, dont sweet
__________________
Non mai abbastanza...
  Reply With Quote
Old 5th November 2007, 07:11 AM   #5
Unique is offline Unique  Greece
diyAudio Member
 
Join Date: Oct 2007
Could you send me the service manual please?
  Reply With Quote
Old 5th November 2007, 11:49 AM   #6
diyAudio Member
 
aparatusonitus's Avatar
 
Join Date: Jan 2004
Location: Split, Croatia
Mail me, and I'll send it today/tomorow.
__________________
Non mai abbastanza...
  Reply With Quote
Old 5th November 2007, 01:45 PM   #7
Unique is offline Unique  Greece
diyAudio Member
 
Join Date: Oct 2007
I am a new user here and i am not allowed to send mails yet. But i have no problem to tell you my e-mail, which is: uniquegr@hotmail.com

Thanks
  Reply With Quote
Old 5th November 2007, 03:16 PM   #8
Unique is offline Unique  Greece
diyAudio Member
 
Join Date: Oct 2007
Now that's what I call quick response!!! Thanks a lot my friend!! ))
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Technics SU-V2X zega55 Chip Amps 5 5th January 2008 01:54 AM
Technics SA-600 ZigDaPig Solid State 0 16th August 2005 01:33 PM
Technics SU-Z22 Rob Flores Parts 0 18th March 2005 01:12 PM
Which Amp to keep - Technics or NAD? maxw Solid State 5 6th December 2004 10:41 AM
technics sl-23 ironfinger43 Analogue Source 0 29th May 2004 05:44 AM


New To Site? Need Help?

All times are GMT. The time now is 11:35 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2