dcx2496 just died. Any thoughts? - diyAudio
Go Back   Home > Forums > Source & Line > Digital Line Level

Digital Line Level DACs, Digital Crossovers, Equalizers, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 3rd March 2006, 01:02 PM   #1
diyAudio Member
 
Join Date: Sep 2002
Location: Australia
Default dcx2496 just died. Any thoughts?

After not touching it for a long time, I thought I might just tweak the bass levels on my three way active dipole. Prior to fiddling, I turned the DCX off, and then back on.

Instead of a cheery welcome screen, I now have a unit that merely gives a dim pulsing screen with no characters at all. The dim pulse on the screen was matched with a sonic pulse through the speakers which I sincerely hope has not damaged my speakers.

Any Behringer experts care to suggest a remedy or a diagnosis? I heard something about poor power supply components.

I have tried a reset to factory by press the two page keys while powering up, and the recovery thingie by pressing the Input A button while powering up.

Nada.

All suggestions grumpily entertained.


Steve
  Reply With Quote
Old 3rd March 2006, 01:37 PM   #2
seoman is offline seoman  Netherlands
diyAudio Member
 
Join Date: Apr 2004
Location: Nijmegen
Try fiddeling with the internal power supply cables.
The connectors can make a bad connection.

I had this problem with de DEQ2496 (allready after 3 days)
after slighty moving the connectors, the problem has not reapeared again. (8 months now)

Good luck

Simon
  Reply With Quote
Old 3rd March 2006, 02:18 PM   #3
diyAudio Member
 
ashok's Avatar
 
Join Date: Jun 2002
Location: 3RS
Maybe you can remove the connector(s) and spray contact cleaner on both pins and socket before re-plugging it.

Cheers.
__________________
AM
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
My Rotel just died hybridfiat Solid State 4 1st August 2008 01:33 AM
M DCX died, what to do? sqlkev Digital Line Level 3 22nd May 2006 07:03 PM
Help Marantz CD-42 MK II died zachi-1 Digital Source 3 27th April 2005 07:17 PM
Need help--powered sub just died mouse Subwoofers 3 29th October 2003 02:18 PM
Right channel of my AR D52 died? roddyama Solid State 1 20th February 2002 11:50 PM


New To Site? Need Help?

All times are GMT. The time now is 05:33 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2