diyAudio

diyAudio (http://www.diyaudio.com/forums/)
-   Digital Line Level (http://www.diyaudio.com/forums/digital-line-level/)
-   -   dcx2496 just died. Any thoughts? (http://www.diyaudio.com/forums/digital-line-level/75134-dcx2496-just-died-any-thoughts.html)

sfdoddsy 3rd March 2006 01:02 PM

dcx2496 just died. Any thoughts?
 
After not touching it for a long time, I thought I might just tweak the bass levels on my three way active dipole. Prior to fiddling, I turned the DCX off, and then back on.

Instead of a cheery welcome screen, I now have a unit that merely gives a dim pulsing screen with no characters at all. The dim pulse on the screen was matched with a sonic pulse through the speakers which I sincerely hope has not damaged my speakers.

Any Behringer experts care to suggest a remedy or a diagnosis? I heard something about poor power supply components.

I have tried a reset to factory by press the two page keys while powering up, and the recovery thingie by pressing the Input A button while powering up.

Nada.

All suggestions grumpily entertained.


Steve

seoman 3rd March 2006 01:37 PM

Try fiddeling with the internal power supply cables.
The connectors can make a bad connection.

I had this problem with de DEQ2496 (allready after 3 days)
after slighty moving the connectors, the problem has not reapeared again. (8 months now)

Good luck

Simon

ashok 3rd March 2006 02:18 PM

Maybe you can remove the connector(s) and spray contact cleaner on both pins and socket before re-plugging it.

Cheers.


All times are GMT. The time now is 08:21 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio


Content Relevant URLs by vBSEO 3.3.2