XMOS USB - miniSharc - PCM5102 - diyAudio
Go Back   Home > Forums > Source & Line > Digital Line Level

Digital Line Level DACs, Digital Crossovers, Equalizers, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 3rd January 2015, 09:00 AM   #1
macsaif is offline macsaif  Slovakia
diyAudio Member
 
Join Date: Aug 2002
Location: Slovakia
Default XMOS USB - miniSharc - PCM5102

Hello,

I am building a digital crossover for my active loudspeakers based od Audiophonics XMOS USB-I2S - miniSharc - and 3x Audiophonics PCM5102 DAC. The crossover is ready and it works fine however I have a problem with startup. If all the boards are connected the XMOS is not recognized by the PC. A can start-up the crossover only if I disconnect minisharc from the XMOS board, connecting the PC to XMOS and then connecting the minisharc to XMOS board. In that case everithing works. whre can be the problem and how can I solve it?

Thank you in advance!

Frank
  Reply With Quote
Old 3rd January 2015, 11:11 AM   #2
Hsmeets is offline Hsmeets  Netherlands
diyAudio Member
 
Join Date: May 2011
Location: Southern part of the Netherlands
Does it behave the same when you connect the USB-I2S directly to one of the PCM5102 (thus without the MinSharc in the chain)?
  Reply With Quote
Old 3rd January 2015, 11:18 AM   #3
macsaif is offline macsaif  Slovakia
diyAudio Member
 
Join Date: Aug 2002
Location: Slovakia
I have not tried, I can try to recable it. Do you think the I2S isolator could help to solve the problem?

Frank
  Reply With Quote
Old 3rd January 2015, 11:36 AM   #4
Hsmeets is offline Hsmeets  Netherlands
diyAudio Member
 
Join Date: May 2011
Location: Southern part of the Netherlands
I2S isolator: don't know. Which one?

If the XMOS USB-I2S behave's the same (not being recognized by your PC) when directly connected to a DAC as when connected to the MiniSharc you'll have to get support from audiophonics.

With PC you mean a PC with Windows operating system? Do you have the possibility to test with Apple or linux? Maybe it's not a hardware but ome software conflict.

Do you have the USB connection to the MiniSharc also in use when you power on your cross-over?
  Reply With Quote
Old 3rd January 2015, 11:48 AM   #5
macsaif is offline macsaif  Slovakia
diyAudio Member
 
Join Date: Aug 2002
Location: Slovakia
I have no USB connected to the minisharc. If I have everithing conncted (also minisharc to USB) and minisharc is not connected to the XMOS it starts up. If I have everithing disconnected, also the dac, etc and the minisharc is connected to XMOS it does not start up. I have win7. After starting up I can connect everithing (all the 3 DAC boards, minisharc, USB to minisharc) and disconnect..... it works.
  Reply With Quote
Old 3rd January 2015, 11:55 AM   #6
Hsmeets is offline Hsmeets  Netherlands
diyAudio Member
 
Join Date: May 2011
Location: Southern part of the Netherlands
Does it make a difference when you power up your cross-over with or without the XMOS connected to your PC (and everything else inside the x-over connected)? Maybe it is recognized after power up but only when not initially connected to the PC.
  Reply With Quote
Old 3rd January 2015, 12:11 PM   #7
macsaif is offline macsaif  Slovakia
diyAudio Member
 
Join Date: Aug 2002
Location: Slovakia
No difference. I can switch it on with or without the USB connection. If the minisharc is connected it is not recognized, when the minisharc is disconnected it works.
I have started to study the minisharc manual if there is any difference if the minisharc is powered via main mower connector or via J2 however there is no any information which pins have to be connected to the source. There are 7 GND pins and 2 3,3V pins. No any information whether they are an input power or output power pins to the DAC. No information which GND pins have to be connected or it is enough if I connect the GND via main power (DC Input).
  Reply With Quote
Old 3rd January 2015, 12:18 PM   #8
Hsmeets is offline Hsmeets  Netherlands
diyAudio Member
 
Join Date: May 2011
Location: Southern part of the Netherlands
The 2 pin connector is there to power the MiniSharc. The 3.3V on the extension header is only output.

The strange thing is that when you connect the XMOS to the Minisharc after it is powered up your PC recognizes the XMOS USB.

I strongly suggest to run a few wires directly to one of the DAC's and see if it behaves the same.

Last edited by Hsmeets; 3rd January 2015 at 12:25 PM. Reason: J2 changed to 2 Pin connector
  Reply With Quote
Old 3rd January 2015, 12:33 PM   #9
Hsmeets is offline Hsmeets  Netherlands
diyAudio Member
 
Join Date: May 2011
Location: Southern part of the Netherlands
Some random thought: what happens if you do not disconnect the I2S wires but leave the MiniSharc un-powered and power it up after the XMOS has powered up.
  Reply With Quote
Old 3rd January 2015, 11:23 PM   #10
macsaif is offline macsaif  Slovakia
diyAudio Member
 
Join Date: Aug 2002
Location: Slovakia
Nothing happens. The XMOS starts op only in case that the 3 wires are disconnected from minisharc(data, bck lrck). I have tried lot of combinations. It always starts up if this 3 wires are disconnected and never if they are connected before the xmos is recognized by PC.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
New Async XMOS 384K/32bit with PCM5102 DAC on ebay luxury54 Digital Source 115 30th June 2015 02:19 PM
PCM5102 Mini USB DAC Schematic and layout critique miniengineer Digital Line Level 2 17th February 2015 01:04 PM
PCM5102 USB DAC for sennheiser HD650 - request for design critique 00940 Digital Line Level 12 24th November 2014 04:14 PM
Leaf Audio XMOS 384k 32bit DAC: PCM5102, TDA1308, PE-65x12 AudioLapDance Digital Source 14 2nd November 2014 07:30 PM
USB to i2s options for minisharc XuMo2 miniDSP 5 19th May 2014 02:13 PM


New To Site? Need Help?

All times are GMT. The time now is 04:12 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.
Copyright 1999-2015 diyAudio

Content Relevant URLs by vBSEO 3.3.2