Build Thread for TPA BIII + Ian Async I2S FIFO + OPC NTD1 + Salas SSLV - Page 53 - diyAudio
Go Back   Home > Forums > Source & Line > Digital Line Level

Digital Line Level DACs, Digital Crossovers, Equalizers, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 23rd June 2013, 03:56 AM   #521
diyAudio Member
 
Join Date: Feb 2009
Location: Brisbane, Australia
It is Si570 not i570 ...


Do you have initialisation with:
Serialx.begin(speed, config)

x is 1, 2, 3 for mega serial port num.

You can use Serialx.available() to check for data being available in the buffer.
  Reply With Quote
Old 23rd June 2013, 01:42 PM   #522
diyAudio Member
 
Join Date: Jul 2009
Yes, I am using SerialX.begin to initialize the serial port. Serialx.available sometime detects there is serial data but most of the time detects nothing. Can see data output from dual clock board Tx but Rx at Arduino always "Low" (with isolator).
  Reply With Quote
Old 23rd June 2013, 11:26 PM   #523
DQ828 is offline DQ828  Australia
diyAudio Member
 
DQ828's Avatar
 
Join Date: Mar 2010
Location: Lake Macquarie, East Coast Australia
Quote:
Originally Posted by bigpandahk View Post
Yes, I am using SerialX.begin to initialize the serial port. Serialx.available sometime detects there is serial data but most of the time detects nothing. Can see data output from dual clock board Tx but Rx at Arduino always "Low" (with isolator).
Pull Up resistors?
  Reply With Quote
Old 24th June 2013, 09:58 AM   #524
DQ828 is offline DQ828  Australia
diyAudio Member
 
DQ828's Avatar
 
Join Date: Mar 2010
Location: Lake Macquarie, East Coast Australia
Hmm, I have started testing the Amanero I have installed in my DAC 1 (DAC 2 BIIISE Amanero works fine) that goes via an Sidecar to the BIII and I am getting bad noise & distortion, no idea why at this stage.
  Reply With Quote
Old 25th June 2013, 12:12 AM   #525
diyAudio Member
 
Join Date: Jul 2009
The Arduino has internal pull up resistors, I've tried to set the Rx pin to "High" and it becomes high, still not detecting any signal from the SI570!!
Amanero is quite unstable, it always gives high pitch noise when playing music, I have to unplug the USB and wait for few seconds until the noise disappear. Its SQ is not as good as WaveIO, the only advantage is playing DSD. I may try some other device if I can't fix the noise problem.
  Reply With Quote
Old 16th July 2013, 01:24 PM   #526
diyAudio Member
 
Join Date: Jul 2009
I use two OTTO II to switch the Amanero to FIFO or BIII. When connect to BIII, it will pass through Acko's isolator board. The Amanero sound great when connected to the FIFO, but serious distortion when directly connected to BIII through Acko isolator. The only device not common to both setup is the Acko isolator, so I concentrate on trouble shoot the isolator. Spent almost two months, replaced two 74G74 and the isolator chip, the power supply to the Amanero but still no help.
Before give-up and try to source other DSD device. Last trial to connect the Amanero to BIII without isolator, the same distortion. Then confirmed the fault not isolator related.
Why the FIFO can make the Amanero distorted sound normal?
  Reply With Quote
Old 17th July 2013, 05:56 AM   #527
DQ828 is offline DQ828  Australia
diyAudio Member
 
DQ828's Avatar
 
Join Date: Mar 2010
Location: Lake Macquarie, East Coast Australia
Quote:
Originally Posted by bigpandahk View Post
I use two OTTO II to switch the Amanero to FIFO or BIII. When connect to BIII, it will pass through Acko's isolator board. The Amanero sound great when connected to the FIFO, but serious distortion when directly connected to BIII through Acko isolator. The only device not common to both setup is the Acko isolator, so I concentrate on trouble shoot the isolator. Spent almost two months, replaced two 74G74 and the isolator chip, the power supply to the Amanero but still no help.
Before give-up and try to source other DSD device. Last trial to connect the Amanero to BIII without isolator, the same distortion. Then confirmed the fault not isolator related.
Why the FIFO can make the Amanero distorted sound normal?
I have my Amanero connected directly to the BIII & it is fine, I had issues with the grounding initially that caused noise. All wires are now straight from the Amanero to the BIII and all is good.
  Reply With Quote
Old 20th July 2013, 12:53 AM   #528
diyAudio Member
 
Join Date: Jul 2009
Thanks DQ828

It is not grounding issue. While had no other method to isolate the problem, I turn the input selection and accidentally changed the setting of the BIII through the Arduino, all distortion went away and beautiful music from BIII

I don't know which setting had been changed.

Now, I can concentrate on the Arduino Code and hope can finish this project soon.
  Reply With Quote
Old 21st July 2013, 11:13 AM   #529
DQ828 is offline DQ828  Australia
diyAudio Member
 
DQ828's Avatar
 
Join Date: Mar 2010
Location: Lake Macquarie, East Coast Australia
Quote:
Originally Posted by bigpandahk View Post
Thanks DQ828

It is not grounding issue. While had no other method to isolate the problem, I turn the input selection and accidentally changed the setting of the BIII through the Arduino, all distortion went away and beautiful music from BIII

I don't know which setting had been changed.

Now, I can concentrate on the Arduino Code and hope can finish this project soon.
I had that problem

Good luck
  Reply With Quote
Old 31st August 2013, 04:40 PM   #530
mcluxun is offline mcluxun  United States
diyAudio Member
 
Join Date: Nov 2010
Newbie check in.
Hey gentlemen
You guys are making something amazing here that I wanted to be part of.
I'm on my planning stage right now.
Which I think I need:
buffalo dac board x1
salas x1
ntd1 x1
And of course everything on the BOM.
Am I correct?

Last edited by mcluxun; 31st August 2013 at 04:53 PM.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Asynchronous I2S FIFO project, an ultimate weapon to fight the jitter iancanada Digital Line Level 3458 24th December 2014 11:01 AM
Ian asynchronous I2S and S/PDIF FIFO KIT group buy iancanada Group Buys 1738 18th December 2014 08:41 AM
FS Quanghao SSLV Salas design merlin el mago Swap Meet 12 17th August 2012 03:06 AM
F.S quanghao salas sslv 1.0 for buffalo dac. back Swap Meet 1 31st July 2012 03:32 AM
Simple FIFO to I2S CPLD, for MCU players / reclocking KOON3876 Digital Line Level 21 19th September 2008 05:00 PM


New To Site? Need Help?

All times are GMT. The time now is 04:39 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2