Intermittent DCX2496 glitch - diyAudio
Go Back   Home > Forums > Source & Line > Digital Line Level

Digital Line Level DACs, Digital Crossovers, Equalizers, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 24th January 2012, 03:01 AM   #1
diyAudio Member
 
Join Date: Nov 2010
Location: South Texas
Send a message via AIM to ComputerJLT
Default Intermittent DCX2496 glitch

not sure if this is an issue with my cable or the dcx but here goes. I just picked up a DCX2496 used, i did my own spdif direct input; i have an rca connector and about 8" of homemade twisted pair wire (dont have any small 75ohm coax) going to the primary side of the oem input transformer (and I cut the traces on the pcb to the xlr input). Also the 110ohm termination resistor has been replaced with 2 paralleled 150ohm 5% resistors (until the 75ohm 1% resistors come in) that measured right at 75ohms.

it works and it seems to work quite well most of the time. A few times now though it'll glitch and the sound will get muddy and dull; i can reset it and it goes back to normal or sometimes it clears up on its own.

i vaguely recall reading about a guy that bypassed the xlr input with a direct spdif in and that cleared up the same issue but i'm still having the problem.

I'm using what i thought was a quality 75ohm composite video cable that is coax that's aprox 4' long from my pc's spdif out to the unit. i'm still waiting on some panel mount rca's so the rca spdif in is just hanging out of the unit. should I ground this?

Also I bought 2 .001uF caps to replace the input transformer and will probably do that when my panel mount jacks come in (along with the caps to do a single ended output right out of the DAC).

Another thing to note, earlier my roomates girlfriend was lighting the stove (electric ignitor) and every time she did that my dcx popped and when music was playing it did the muddy sound thing. Does this mean my cable is really crap or is it the ungrounded floating rca spdif input? Also my house is quite old and none of the plugs in my room have a ground/neutral on the 3 prong plug.
  Reply With Quote
Old 24th January 2012, 05:00 AM   #2
diyAudio Member
 
Join Date: Jul 2005
Location: Fairfield, IA
There's a fair amount of discussion about this in several forums. Seems the occasional dull sound is caused by the input receiver having occasional lockups, and requiring a full reset, exactly as you are doing.

If you do a Google search on "dcx2496 dull sound" you should be able to find several of the discussions and fixes. One of the best replies is:

24bits 192KHz oversampling digital input for the DCX2496
Selectronic in France has developed some upgrade boards for the dcx2496. They can also do the full-bore mod for you or sell you a fully modded unit which fix this issue by completely replacing the input chip, and then a lot of other stuff (not cheap, but the word is that it sounds incredible).

Good luck!
__________________
Commercial Site: www.HolisticAudio.com
  Reply With Quote
Old 24th January 2012, 05:08 AM   #3
diyAudio Member
 
Join Date: Jul 2005
Location: Fairfield, IA
Default Pilgham audio

Another fix comes from Pilgham audio in the Netherlands, using the Oettle solution. Also highly reviewed. Check it at:

Pilgham Audio - SRC/Clock
__________________
Commercial Site: www.HolisticAudio.com
  Reply With Quote
Old 24th January 2012, 11:20 PM   #4
diyAudio Member
 
Join Date: Nov 2010
Location: South Texas
Send a message via AIM to ComputerJLT
i dont think it was a clock issue; i grounded the rca plug to the chassis and all last night it was fine. right now i'm working on making a passive single ended out with some dayton caps that just came in. i'll have a proper rca in thats grounded and i'll probably remove the original input trafo and replace it with caps to see what happens
  Reply With Quote
Old 26th January 2012, 03:53 AM   #5
diyAudio Member
 
Join Date: Nov 2010
Location: South Texas
Send a message via AIM to ComputerJLT
so far so good; i didn't even swap the trafo for cap coupling.... guess you need to ground the rca! well also i did shorten my homemade twisted pair and tighten it up some but i'm not sure how much of a difference that made.

On a side not capacitvely coupled single ended output sounds fantastic! night and day difference. I'm using Dayton Audio 6.8uF coupling caps and i accidentally ordered 3.3uF caps instead of 3.3nF for the low pass filter. So i'm rocking some .01uF radio shack polyester film caps until the proper 3.3nF caps come in; and it still sounds amazing!!! can't wait till I get all 6 channels setup with the right caps.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
MiniDSP vs DCX2496 vs DCX2496-Modded vs DEQX gainphile miniDSP 20 14th September 2011 09:24 AM
intermittent hum balance Instruments and Amps 4 17th December 2008 01:01 AM
How do i solve the intermittent input of DCX2496? tolits Digital Line Level 0 24th June 2006 06:23 PM
Is this glitch ? Bernhard Digital Source 4 11th April 2005 01:35 PM
Working amp witha glitch - or two. lazyfly Solid State 5 21st June 2004 03:24 PM


New To Site? Need Help?

All times are GMT. The time now is 12:32 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2