Asynchronous I2S FIFO project, an ultimate weapon to fight the jitter - Page 266 - diyAudio
Go Back   Home > Forums > Source & Line > Digital Line Level

Digital Line Level DACs, Digital Crossovers, Equalizers, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 6th April 2013, 03:56 PM   #2651
diyAudio Member
 
nvduybom's Avatar
 
Join Date: Aug 2009
Location: Da Nang, Viet Nam
Hi Ian,

I upgraded to double dual clock with crystek 45Mhz & 49Mhz. The sound improved, but I get the error when playing the files with sample rate 44.1 Khz & 96 Khz .

- Sample Rate 96KHz :
All times playing 96kHz files then all Leds on Clock board is flashing. On FIFO, the Led "Emty" is light. No sound.

- Sample Rate 44.1kHz :
On Clock board, The Leds 48Khz & 96Khz is light. On FIFO, the Led "Emty" is light. No sound.
But I noticed that when I playing the file 88khz or 176 Khz, then continue to playing the files 44.1 Khz is ok.

I read but not seen anyone with this error.

Ah, it is necessary to add the 100n capacitor and 1uF for Crystek adapter board ?.

I use PC with Jriver 18 + Amanero .

Thank you .
Attached Images
File Type: jpg IMG_0606.JPG (291.7 KB, 518 views)
File Type: jpg IMG_0610.JPG (277.4 KB, 503 views)
__________________
http://www.vnav.vn/forum
  Reply With Quote
Old 7th April 2013, 05:08 AM   #2652
diyAudio Member
 
nvduybom's Avatar
 
Join Date: Aug 2009
Location: Da Nang, Viet Nam
This error is caused by U1 jumper on Clock board , (long time I think caused by software & firmware ). I see it loose and replace new jumper. Everything works fine.
__________________
http://www.vnav.vn/forum
  Reply With Quote
Old 7th April 2013, 01:48 PM   #2653
diyAudio Member
 
iancanada's Avatar
 
Join Date: Dec 2009
Location: Toronto
Quote:
Originally Posted by nvduybom View Post
This error is caused by U1 jumper on Clock board , (long time I think caused by software & firmware ). I see it loose and replace new jumper. Everything works fine.
Looks good. Glad you fix it. Both hardware and software were confirmed many time should be no problem.

Nice weekend.

Ian
__________________
Ian GBV - I2S to PCM converter board & FIFO KIT
http://www.diyaudio.com/forums/group...ml#post3662743
  Reply With Quote
Old 7th April 2013, 09:20 PM   #2654
diyAudio Member
 
Join Date: Jan 2011
Location: sitting down
Greetings,

I reolved my issue with the Si clock and synching the es9023 dac. I noticed that the clcok was set to 90/98 Mhz. The es9023 didn't like that speed. I switched to 45/49 and all is good. tried 44.1 and 48khz files without any glitch.

Now, I would like to drive a dual mono with the Si clock board in asynch mode for now. So I soldered the ufl on the second I2S outputs. I get no signal on the second set. Only one channel (N the top set) is functionning.


Is there anything else needed other than the ufl connectors? Jumper I am missing perhaps?

regards.
  Reply With Quote
Old 7th April 2013, 10:56 PM   #2655
mcluxun is offline mcluxun  United States
diyAudio Member
 
Join Date: Nov 2010
Hey all
I'm trying to make a case of this kit including the spdif board.
Did any one make a drill pattern for spdif board before?
I searched this thread but didn't get any luck.
  Reply With Quote
Old 8th April 2013, 01:22 AM   #2656
diyAudio Member
 
iancanada's Avatar
 
Join Date: Dec 2009
Location: Toronto
Quote:
Originally Posted by necplusultra View Post
Greetings,

I reolved my issue with the Si clock and synching the es9023 dac. I noticed that the clcok was set to 90/98 Mhz. The es9023 didn't like that speed. I switched to 45/49 and all is good. tried 44.1 and 48khz files without any glitch.

Now, I would like to drive a dual mono with the Si clock board in asynch mode for now. So I soldered the ufl on the second I2S outputs. I get no signal on the second set. Only one channel (N the top set) is functionning.


Is there anything else needed other than the ufl connectors? Jumper I am missing perhaps?

regards.
Hi necplusultra,

Here is the schematic of the output section of the Si570 clock board. It would easy for you to address the problem with it.

Hope it helps.

Regards,

Ian
Attached Images
File Type: png Si570outputSch.png (39.6 KB, 393 views)
__________________
Ian GBV - I2S to PCM converter board & FIFO KIT
http://www.diyaudio.com/forums/group...ml#post3662743
  Reply With Quote
Old 8th April 2013, 01:25 AM   #2657
diyAudio Member
 
iancanada's Avatar
 
Join Date: Dec 2009
Location: Toronto
Quote:
Originally Posted by mcluxun View Post
Hey all
I'm trying to make a case of this kit including the spdif board.
Did any one make a drill pattern for spdif board before?
I searched this thread but didn't get any luck.
George has the drawing.

Ian
__________________
Ian GBV - I2S to PCM converter board & FIFO KIT
http://www.diyaudio.com/forums/group...ml#post3662743
  Reply With Quote
Old 8th April 2013, 01:25 AM   #2658
diyAudio Member
 
Join Date: Feb 2009
Location: Brisbane, Australia
Quote:
Originally Posted by nvduybom View Post

Ah, it is necessary to add the 100n capacitor and 1uF for Crystek adapter board ?.
I just noticed this hadn't been addressed. You should not need those caps when using the Crystek XO. The Crystek units have decoupling internally I believe so do not require additional decoupling on the adapter PCB.
  Reply With Quote
Old 8th April 2013, 03:03 AM   #2659
diyAudio Member
 
nvduybom's Avatar
 
Join Date: Aug 2009
Location: Da Nang, Viet Nam
Quote:
Originally Posted by hochopeper View Post
I just noticed this hadn't been addressed. You should not need those caps when using the Crystek XO. The Crystek units have decoupling internally I believe so do not require additional decoupling on the adapter PCB.
Thanks you ,

I thought why not practical test? . After listening to both cases, I likes the sound with no capacitors . The sound more open, especially in high frequencies .
__________________
http://www.vnav.vn/forum
  Reply With Quote
Old 8th April 2013, 10:02 AM   #2660
BKSL is offline BKSL  Slovakia
diyAudio Member
 
Join Date: Mar 2012
Location: Slovak Republic
to iancanada:

Is it possible to disable digital filters in your "hardware" to achieve untouched digital input on analog side? No decimation, no DC removing etc.

If i connect 4 signals of I2S bus from CMI8788 chip to your hardware, should it works ?
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
XMOS-based Asynchronous USB to I2S interface Lorien Digital Source 2111 Yesterday 05:21 AM
exaU2I - Multi-Channel Asynchronous USB to I2S Interface exa065 exaDevices 1357 3rd March 2014 08:51 PM
DAC chip selection + I2S jitter questions drwho9437 Digital Line Level 2 26th July 2010 12:50 PM
Simple FIFO to I2S CPLD, for MCU players / reclocking KOON3876 Digital Line Level 21 19th September 2008 04:00 PM
asynchronous reclocking and low jitter clocks ash_dac Digital Source 3 8th February 2005 09:22 AM


New To Site? Need Help?

All times are GMT. The time now is 05:35 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2