diyAudio

diyAudio (http://www.diyaudio.com/forums/)
-   Digital Line Level (http://www.diyaudio.com/forums/digital-line-level/)
-   -   Problem DIY CS4398 DAC (http://www.diyaudio.com/forums/digital-line-level/181418-problem-diy-cs4398-dac.html)

pnb 18th January 2011 10:26 PM

Problem DIY CS4398 DAC
 
2 Attachment(s)
Or it could be me !
I have no CD player with an optical o/p nor a working scope to check this DAC and I need some suggestions.

I am trying to test it with my soundcard (Emu 1212M pci) and RightMark Audio Analyser. I have loopback tested the soundcard, both optical and analogue, and it has checked out fine.
I am now trying to test the DAC at 24 bit and 48kHz and both RightMark and the DAC are set accordingly (I think), but no output. Touching a remove analogue connection increases the hum.
The soundcard software is DSP PatchMix which I am still trying to understand so I might have something wrong there.
I have attached a photo of my board and the manufacturers datasheet.

Any suggestions please?
pnb

singa 20th January 2011 04:01 AM

Hi,
Your post is not clear about what you want to say. Are you saying this
4398 dac you bought fully built is not working? And you don't have a cd player? Well just use your pc but since this is a dac ,it takes only SPDIF format signal only.So connect spdif from soundcard eg.coaxial (rca) , optical or usb.Use a rca to 3.5mm adapter to listen with headphone or input to line in of soundcard.

You have a professional emu 1212 pci and loopback tested OK.
I think I know what is your problem.
1. Assuming M2,M3 toggle switch for sampling rate is correct at 24bit 48khz.

2. M0,M1 this depends on which dac you are supplied with (CS4398) the so check the manual/datasheet.CS4398 can decode several format but will default to one ,see datasheet.
It is the japanese standard or european standard (sony/philips)
left or right justified I have forgotten but check dac/soundcard ( which format it is using) manual.
Try all of them in any case.

3.Input spdif selector look at picture to set correct jumpers for cox (coaxial rca),opt and usb.Unfortunately pcb does not autoselect
so it's done manually.

If step 1,2 and 3 is correct your dac should work.If it does not then check
your soundcard settings.It is straight forward.

I do not know what RightMark software does.You also must know if DSP patchmix is 24 bit capable or not or else switch to 16 bit. Singa.

pnb 23rd January 2011 03:11 PM

1 Attachment(s)
Thanks Singa for your comments.
The DAC I am trying to test is the one in the photo, complete and supposedly tested.
I have been lent a CD/DVD player with an Optical output apparently at 48kHz so I will experiment with that.
The DA is a CS4398, datasheet attached. However the DAC datasheet in the zip file of the original post shows the settings and I have used those.
DSP Pathmix comes with the EMU card and is 24 bit compatible.

pnb

sendler 23rd January 2011 03:29 PM

What problem?
 
What problem are you trying to fix? Does it play? Ask on the thread:
.
http://www.diyaudio.com/forums/digit...ml#post2443314
.
Quote:

Originally Posted by pnb (Post 2443316)
Thanks Singa for your comments.
The DAC I am trying to test is the one in the photo, complete and supposedly tested.
I have been lent a CD/DVD player with an Optical output apparently at 48kHz so I will experiment with that.
The DA is a CS4398, datasheet attached. However the DAC datasheet in the zip file of the original post shows the settings and I have used those.
DSP Pathmix comes with the EMU card and is 24 bit compatible.

pnb


pnb 23rd January 2011 03:50 PM

Quote:

I am trying to test it with my soundcard (Emu 1212M pci) and RightMark Audio Analyser. I have loopback tested the soundcard, both optical and analogue, and it has checked out fine.
I am now trying to test the DAC at 24 bit and 48kHz and both RightMark and the DAC are set accordingly (I think), but no output. Touching a remove analogue connection increases the hum.
The soundcard software is DSP PatchMix which I am still trying to understand so I might have something wrong there.
I have attached a photo of my board and the manufacturers datasheet.
pnb

singa 24th January 2011 03:12 AM

Hi pnb,
Are the power supply voltages correct? Have all the 5 led light up
when powered up? Singa

You have to set M1,M0 and M2,M3 ,at the moment it is I2S up to 24bit
and single speed up to 50Khz. Hat is EMU format?
PS your input selector is set to opticle/TORX now.
Singa.

pnb 25th January 2011 04:22 PM

Hi Singa,
Yes all the psu leds are lit, I haven't actually checked the voltages.
The RMAA and DSP PatchMix software are both set for 24 bit 48kHz.

pnb

pnb 5th February 2013 06:02 PM

1 Attachment(s)
I have returned to this project after moving house and starting a new business, and I am determined to get it to work!

First off the DAC settings. I want to test at 24bit and 48kHz, so its the DIP switch settings I need help with.(M1 M0, M3, M2)
I am unsure what matches my sound card (left, right or I2S) so I have attached the pdfs of it spec pages(2).
I intend to check its frequency response and distortion with my card and RMAA,

Hope that is enough info for someone to help

Thanks


All times are GMT. The time now is 01:59 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio


Content Relevant URLs by vBSEO 3.3.2