SRC4192 weird output - diyAudio
Go Back   Home > Forums > Source & Line > Digital Line Level

Digital Line Level DACs, Digital Crossovers, Equalizers, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 11th September 2010, 05:18 PM   #1
afo is offline afo  Germany
diyAudio Member
 
Join Date: Feb 2008
Default SRC4192 weird output

Hi,

I am just trying to set up a configuration with the Twister Pear Audio Metronome ASRC module. I feed it from a uC with 48kHz audio and want it to resample to 192kHz.
I use the configuration as proposed in the TPA manual. Actually it seems the output of the SRC4192 is not influenced by the input at all. While there is no input on PCMIN (Data line is 0 all the time, BCK and LRCK are running) the output on PCMOUT shows some spikes all the time. These spikes look identically when input is coming on PCMIN.
After the metronome ASRC I have the COD module, which has no output on the signal out all the time.

Any ideas?

Thanks!
  Reply With Quote
Old 15th September 2010, 10:27 PM   #2
afo is offline afo  Germany
diyAudio Member
 
Join Date: Feb 2008
I did some measurements of input and output signal. Input was a 1kHz sine wave on one channel only.
Ch1 is data, Ch2 LRCK and Ch3 BCK.
LRCK is 50Hz because the source is not clocked very exact, but this is due to the testing environment atm. I don't think this should be a problem for the SRC4192.

Click the image to open in full size.

Bigger scale:
Click the image to open in full size.

You can see that the data line has one clock cycle delay to the edge on LRCK, as it is described in SRC4192 datasheet.

The output of SRC4192 looks like this:

Click the image to open in full size.

Actually this is unchanged, no matter if there is input or not.

Any ideas what might go wrong? Might something be wrong with the input signal, which I am not seeing right now?
  Reply With Quote
Old 5th March 2013, 09:47 AM   #3
galeb is offline galeb  Spain
diyAudio Member
 
Join Date: Apr 2008
Hi,

I don't know if you've post this a long time ago. Can I see your schematic?, I've configured this SRC some time ago, and I had some problems, but I've solved them. Maybe I can help you.

Kind regards,
__________________
galeb saleh
Sarte Audio Elite´s technical audio department
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Weird inverted output from codec....(with pics) wildswan Digital Line Level 1 30th July 2010 05:04 PM
Sundown SAE-1200Dv1 Weird output issue possible Fet problem? RosDaddy Car Audio 7 11th April 2010 03:12 AM
Replacing 5-pin DIN inputs on a Telefunken Radio? +weird speaker output? hageir Tubes / Valves 8 19th January 2008 08:59 PM
SRC4192 Use... MWP Digital Source 33 26th April 2005 08:17 PM
AD1896 vs SRC4192 Marek Digital Source 4 8th November 2003 08:05 PM


New To Site? Need Help?

All times are GMT. The time now is 10:57 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2