Theta DS ProPrime II - HELP!!! - diyAudio
Go Back   Home > Forums > Source & Line > Digital Line Level

Digital Line Level DACs, Digital Crossovers, Equalizers, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 14th December 2009, 11:02 AM   #1
JMPires is offline JMPires  Portugal
diyAudio Member
 
Join Date: Sep 2009
Location: Porto
Default Theta DS ProPrime II - HELP!!!

Hi,

I bougth recently the DAC from ebay, but have a major problem, the DAC is not working.

The packadge arrived safely and i didn't saw any signs of damage on transit.
The seller says that the DAC was working on UK. I can listen the electrical noise of power transformer, but nothing hapen. The power led is off.
The DAC is a European model.

I think that the seller used Theta DSPro Prime II Dac + Theta Timebase Linque Conditioner Jitter Buster, but i only bougth the DAC.

Any ideas?

Regards
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Theta DS Pro Basic II rastanearian Digital Line Level 1 3rd January 2010 09:38 PM
Theta Amp problem ZZZDave Tubes / Valves 8 29th April 2009 03:03 PM
R-Theta Group Buy Anyone? Coulomb Group Buys 154 2nd April 2009 04:49 PM
r-theta heatsinks syn08 Swap Meet 0 2nd March 2009 11:26 PM


New To Site? Need Help?

All times are GMT. The time now is 02:26 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2