Noisy ADC - diyAudio
Go Back   Home > Forums > Source & Line > Digital Line Level

Digital Line Level DACs, Digital Crossovers, Equalizers, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 20th May 2009, 01:27 PM   #1
diyAudio Member
 
5th element's Avatar
 
Join Date: Oct 2002
Location: England
Default Noisy ADC

I've built an ADC around a PCM4204.

http://focus.ti.com/lit/ds/symlink/pcm4204.pdf

using an input buffer as is detailed in the data sheet, around an OPA1632

http://focus.ti.com/lit/ds/symlink/opa1632.pdf

The design was pretty much exactly as TI outlined.

It's built on a double sided PCB with the underside acting as a ground plane, all with surface mount parts, except the ADC chip itself which is on an SSOP>DIL adaptor - I know, not perfect, but I need to be able to remove the chip easily.

The PCB also has a DAC on it too. The digital ground is shared for each of the chips (PCM1794 and PCM4202), but I've given two separate ground planes for the analogue sections, where they are joined to the digital one 'beneath' the converters.

The chips are fed the Bit clock, Master clock and LR clock from an M Audio sound card. With the DAC being fed data also, and the ADC chip sending data into the sound card.

Everything is powered by ALW super regs, with a clean DC feed coming in from an external power supply.

Nothing is oscillating.

Obviously this is inside a PC, so not the quietest of environments.

The DAC performs flawlessly, no audible noise of any kind, no hiss no hum etc.

But the ADC is another story - its noisy.

The bit clock operates at 64fs so shouldn't be a problem.

Signal does bleed from the DAC to the ADC, by what I assume is EMI.

Click the image to open in full size.

for example. The DAC is producing a 1khz sine wave with nothing connected to the ADCs input.

However if I mute the output we get.

Click the image to open in full size.

As you can see we're getting -84.3dB on the input for both channels like this. However this isn't reliable. I've wired in a switch that allows me to reset the ADC. Resetting makes this happen.

Click the image to open in full size.

Some spikes at certain frequencies and the noise level has risen, quite noticeably on the right channel. This is typically how the ADC performs. About 10dB more noise on the right channel then the left.

Distortion is decent, but as the signal bleeds through from the DAC I get better results if I mute the output channel not being used.

For example -

Click the image to open in full size.

Here is the left channel on the ADC being measured, with both the left and right channel on the DAC being active.

However if I mute the right channel on the DAC I end up with -

Click the image to open in full size.

Quite a difference. And the same for the right channel -

Click the image to open in full size.

^With both channels active on the DAC^

Click the image to open in full size.

With the left channel output on the DAC muted.

The left channel performs better then the right one. If I could eliminate the DACs signal dirtying the ADCs input, I reckon the distortion could be quite a bit lower.

The noise from the ADC isn't caused by the input buffer, as I've disconnected it and the noise behaves in exactly the same way. So it seems the problem lies within the ADC chip itself.

Is any part of the ADC particularly sensitive and could result in the device being noisy? And how, with nothing changing, a simple reset causes a degradation in performance. Or causes an improvement.

I wouldn't necessarily mind this, if it remained constantly at ~-85dB for both channels. Like this RightMark Audio Analyser gives me a dynamic range of 96dBA, which is acceptable. But more often then not, its considerably worse.

So anyone any ideas? or tips on how to improve the performance?

Thanks in advance,

Matt.

P.S. - I have connected the I2S data out directly to the data in on the soundcard, just to see what performance the chip was capable of and I got something in the region of 0.000002% distortion and 0.000008% distortion+noise. So that doesn't seem to be a bottleneck.
__________________
What the hell are you screamin' for? Every five minutes there's a bomb or somethin'! I'm leavin! bzzzz!
  Reply With Quote
Old 20th May 2009, 05:35 PM   #2
diyAudio Member
 
5th element's Avatar
 
Join Date: Oct 2002
Location: England
I thought I'd just add, the I2S data line coming out of the ADC is stable, waveform wise. But the wave bounces up and down.
__________________
What the hell are you screamin' for? Every five minutes there's a bomb or somethin'! I'm leavin! bzzzz!
  Reply With Quote
Old 8th August 2009, 11:29 PM   #3
diyAudio Member
 
5th element's Avatar
 
Join Date: Oct 2002
Location: England
To resurrect my own thread.

I am going to rebuild this the next time I make some PCBs and I'm looking to improve its performance.

First I'm going to separate the DAC and ADC onto two different PCBs and shield them both to cut out the interference. I've played around with sheets of metal and carbon fibre as shields and they both show improvement, its just impractical to modify the current PCB.

I've compared the PCB I've designed with the evaluation board from TI and they are very similar. The only major difference is that my 4202 is on a SSOP to DIL adaptor and the Texas board has it soldered directly.

The SSOP adaptor has a 'ground plane' or rather a layer of metal beneath the chip and does allow you to solder some decoupling parts directly to the pins. As a result I tried soldering decoupling caps directly onto both voltage references and the digital power pin, this didn't really improve anything.

Is this the kind of thing that will improve decently if the chip is soldered directly to the PCB instead of the adaptor? I would prefer to keep using the adaptor if possible.

I'm not trying to perform any miracles with this I'd be happy with a 10-20dB improvement in the noise performance, so any suggestions would be really appreciated. Technically speaking I should be able to get that kind of improvement I think, it's just knowing how.

I have tried having only the ADC powered, with the DAC off and this didn't improve anything either.
__________________
What the hell are you screamin' for? Every five minutes there's a bomb or somethin'! I'm leavin! bzzzz!
  Reply With Quote
Old 9th August 2009, 12:22 AM   #4
diyAudio Member
 
5th element's Avatar
 
Join Date: Oct 2002
Location: England
I thought I'd just add that I have had the DAC and ADC combo perform with 0.001% Distortion and 0.004% Distortion + Noise, under the best case scenario. A good reset on the ADC and with temporary shielding in place.

I'm fairly confident that the DAC is performing excellently at all times it's just the ADC is temperamental and it's this more then anything that I'd like to address.

Why one minute would it give 0.008% as the noise floor, and at the push of a button advance to 0.015%?
__________________
What the hell are you screamin' for? Every five minutes there's a bomb or somethin'! I'm leavin! bzzzz!
  Reply With Quote
Old 29th August 2009, 12:35 AM   #5
diyAudio Member
 
5th element's Avatar
 
Join Date: Oct 2002
Location: England
Well not content with mediocre performance I rebuilt the DAC and ADC and I'm happy to report I'm getting great results.

So far everything is just a crazy jumble of wires next to the PC, so I'm sure there's room for improvement.

The first picture is just the ADC running with no input.

The second is the DAC feeding my Preamp/Active crossover, where the signal is buffered and sent through a TPA6120 headphone amp. I then take the signal out of the headphone socket and back into the ADC. The noise floor rises somewhat as a result of this, but is still low enough.

Interestingly enough I did manage to get a reading with 0.00032% distortion at 48khz, but I didn't screen shot that. I find that pretty amazing considering that's better then the spec for the PCM1794.

I will probably update this thread with more pictures and details after I've tidied everything up a little.
Attached Images
File Type: gif ADC1.gif (160.8 KB, 45 views)
File Type: gif ADC2.gif (152.1 KB, 34 views)
__________________
What the hell are you screamin' for? Every five minutes there's a bomb or somethin'! I'm leavin! bzzzz!
  Reply With Quote
Old 30th August 2009, 11:22 PM   #6
diyAudio Member
 
5th element's Avatar
 
Join Date: Oct 2002
Location: England
The first picture is of the ADC board itself. It seems that removing the SSOP>DIL adaptor really did help the performance significantly.

The second picture is one of the two DACs (Dual mono) they are identical so showing the other one wouldn't really achieve anything other then wasting server space. Here I decided to use the TPA6120 as the differential/output and I have to say this chip is amazing. I've used it as a headphone amp for a while now and love it, but it's great as a line driver too. Great specs, will probably drive any sensible load + cable and best of all is very affordable. Compared to the other DAC, which was stereo and used OPA627s for the differential, I have to say that subjectively, the high frequencies especially sound much cleaner and clearer then before - The signal after the DAC passes through two AD8160s, another TPA6120 then into the HD555s with a DACT stepped pot controlling the volume.

The increase in quality doesn't just stop with the treble, everything just sounds better, and quieter. The main reason I'm attributing to this is the balanced signal. The DACs are in the bottom of a computer, where there is a lot of inherent system noise - not that it really shows up with any of the tests ARTA throws at it though - The noise floor is below the threshold of hearing as is the distortion, but due to the balanced nature of the DAC/ADC I'm sure any system noise would be cancelled out. The Pre amp/Active crossover/Headphone amp however, isn't so lucky. With the single ended signal I had a ground connection between it and the PC. The noisy ground could have easily impacted on the sound quality.

With balanced I can break the ground connection, leaving the Pre amp freer from the noise of the PC. Not only this, but any noise added to the signal before it reaches the Pre is removed, or significantly reduced, before it is passed on to the rest of the system.

I highly recommend trying this kind of approach as it really sounds fantastic
Attached Images
File Type: jpg ADC.1.jpg (541.9 KB, 81 views)
File Type: jpg DAC.jpg (534.5 KB, 77 views)
__________________
What the hell are you screamin' for? Every five minutes there's a bomb or somethin'! I'm leavin! bzzzz!
  Reply With Quote
Old 30th August 2009, 11:29 PM   #7
diyAudio Member
 
5th element's Avatar
 
Join Date: Oct 2002
Location: England
The final picture here represents the best performance I've had for distortion out of this. The figure of 0.00032% is quite amazing in my opinion as it shows TI really do show numbers your typically able to achieve with their chips. The noise of the ADC is lower then this when the Pre isn't connected to it. From a picture above you can see that the noise floor = -111dB and I think TI quote -105dB for noise + distortion, which I'd get if the Pre amp wasn't 'so' noisy.
Attached Images
File Type: jpg !.jpg (137.9 KB, 70 views)
__________________
What the hell are you screamin' for? Every five minutes there's a bomb or somethin'! I'm leavin! bzzzz!
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Noisy NAD 705 squirrel69 Solid State 6 7th April 2006 02:37 AM
noisy noisy noisy noisy noisy tube dsavitsk Tubes / Valves 50 20th February 2006 05:07 PM
help on P1.7 (Noisy) pamaz Pass Labs 9 26th August 2004 03:21 PM
How can i use a noisy PSU ? Garbz Solid State 5 3rd January 2004 01:15 AM
ESP P3A amp, very noisy DaViruz Solid State 33 16th November 2002 07:07 PM


New To Site? Need Help?

All times are GMT. The time now is 10:15 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2