Problem with a model of WR125S - diyAudio
Go Back   Home > Forums > Commercial Sector > Manufacturers > CSS

CSS Creative Sound Solutions (CSS) is a service-oriented provider of high-value speaker components for the DIY loudspeaker builder

Reply
 
Thread Tools Search this Thread
Old 16th November 2012, 11:46 PM   #1
pegodk is offline pegodk  Denmark
diyAudio Member
 
Join Date: Apr 2012
Location: Copenhagen, Denmark
Default Problem with a model of WR125S

Hello CSS!

I've recently bought a lot of drivers second hand including 2 FR125S and 2 WR125S. There's a problem with one of the WR125S though. The coil seems to be scratching the side of the phase plug making an ugly sound especially at high excursions. I've tried a couple of things (putting a rubber band around the coil to pull it into place for example) but nothing really seems to work. Do you have any ideas that could maybe help me?

Best regards
Peter
  Reply With Quote
Old 17th November 2012, 01:17 AM   #2
frugal-phile(tm)
diyAudio Moderator
 
planet10's Avatar
 
Join Date: Oct 2001
Location: Victoria, BC, NA, Sol III
Blog Entries: 5
Check to make sure nothing got into the voice coil gap.

dave
__________________
community sites t-linespeakers.org, frugal-horn.com, frugal-phile.com ........ commercial site planet10-HiFi
p10-hifi forum here at diyA
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kenwood model 600 bias problem reddish75 Solid State 8 4th May 2012 03:08 PM
IR2011 OrCAD Capture simulation model problem pha0001 Class D 4 16th January 2012 11:51 AM
Oscilloscope Channel 1 problem on BK Precision model 2120 albertho Parts 1 20th October 2007 10:21 PM
hk 670 problem(the vintage one, not the 2001 model) DragonMaster Solid State 7 8th April 2006 01:19 PM
Tube Spice Model Problem valveitude Tubes / Valves 5 5th July 2005 01:56 AM


New To Site? Need Help?

All times are GMT. The time now is 02:42 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2