please help - diyAudio
Go Back   Home > Forums > Amplifiers > Class D

Class D Switching Power Amplifiers and Power D/A conversion

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 12th February 2007, 03:52 AM   #1
diyAudio Member
 
Join Date: Feb 2007
Location: dallas texas
Send a message via Yahoo to DdoubleUtwenty1
Default please help

i just assumed a memphis 16mc2000b amplifier and im interested in fixing it. however ii doesnt work properly. When i hook it up it lites up propperly/ no protection light is what i mean. just the green but no sound except when i turn the gain switch up and down. then it just popps through the speakers loudly. What are the possible problems and how hard do you think it would be to fix it. Do you know of any places i could send it.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



New To Site? Need Help?

All times are GMT. The time now is 12:03 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2