Lepai T-Amp with TA2020 - Page 131 - diyAudio
Go Back   Home > Forums > Amplifiers > Class D

Class D Switching Power Amplifiers and Power D/A conversion

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 11th November 2012, 12:48 AM   #1301
diyAudio Member
 
sofaspud's Avatar
 
Join Date: Nov 2005
Location: San Antonio
Did anyone ever come up with a schematic for the blue board LP-2020A+?
__________________
It is error only, and not truth, that shrinks from enquiry. - Thomas Paine
  Reply With Quote
Old 11th November 2012, 01:42 PM   #1302
diyAudio Member
 
Join Date: Sep 2011
Changing the chip isn't that bad. I've done it once.
And I didn't need a schematic on my one when I started modding, as I just bypassed everything so there's just a cap from rca to chip input and then replaced the necessary components on the rear end.
I love how simple it is
  Reply With Quote
Old 12th November 2012, 02:14 AM   #1303
diyAudio Member
 
Join Date: Aug 2008
Quote:
Originally Posted by sofaspud View Post
Did anyone ever come up with a schematic for the blue board LP-2020A+?
The red board (shouldn't be much different from the blue board) is here:
LP-2020A+ mod thread
__________________
Tyler
  Reply With Quote
Old 17th November 2012, 11:08 AM   #1304
danzz is offline danzz  Spain
diyAudio Member
 
Join Date: Mar 2012
Hi everyone..
I recieved my lepai last week, I had already ordered all caps, coils and op amp to modify them, the first thing I did was change the op amp... wich it was a total disaster, Im not good soldering so tiny things, and after diferent tries, only once did work properly, then I thought that it was done ok, after that I changed the output coils, then when I tried it, didnt work, but it seemed to be the op amp again, so I bypassed and worked well, of course volume pot and tone control didnt work, so then I changed the output caps, all with wima caps, tried and worked, then I changed the 220uf caps and the 0,1uf cap beside the chip and then it stoped working.... What I could I had done wrong!?... How can I check if the chip its burnt!?...

Thanks in advanced!!!
  Reply With Quote
Old 17th November 2012, 05:20 PM   #1305
diyAudio Member
 
Join Date: Sep 2012
I imagine you're using too much heat when you solder. Its a balance between not enough and too much. In your case I would replace the op amp with an 8-pin socket so you can use a fresh op-amp without exposing it to heat.
  Reply With Quote
Old 19th November 2012, 01:36 PM   #1306
diyAudio Member
 
Join Date: Nov 2012
Newb here,

I have the new version Lepai, and I can't get good FM signal through this amp when connected. I only did 1 mod, which is add a regulator because my bike gets 14.8v at high revs and the amp shuts off. But I had FM problems before the mod. I tried putting a y-adapter so I can hear the FM with headphones. Clean as a whistle. As soon as I connect it to the amp via 3.5mm or rca, immediately weak reception. I know that the FM antenna for the MP3 player is utilizing the audio cable.

What mod I can do to get clean FM signal?
  Reply With Quote
Old 19th November 2012, 01:55 PM   #1307
diyAudio Member
 
radiosmuck's Avatar
 
Join Date: Jul 2012
Location: Montreal
Quote:
Originally Posted by thompson90 View Post
Newb here,

I have the new version Lepai, and I can't get good FM signal through this amp when connected. I only did 1 mod, which is add a regulator because my bike gets 14.8v at high revs and the amp shuts off. But I had FM problems before the mod. I tried putting a y-adapter so I can hear the FM with headphones. Clean as a whistle. As soon as I connect it to the amp via 3.5mm or rca, immediately weak reception. I know that the FM antenna for the MP3 player is utilizing the audio cable.

What mod I can do to get clean FM signal?
Interesting, I have experienced the same trouble with a 2020 amp trying to amplify an FM signal. I am using the amp for my main domestic setup and have given up on FM and use internet radio.
I have both the Lepai and a SMSL 2020 which I believe has all the mods and the both have problems with FM.
  Reply With Quote
Old 19th November 2012, 02:04 PM   #1308
diyAudio Member
 
Join Date: Nov 2012
Quote:
Originally Posted by radiosmuck View Post
Interesting, I have experienced the same trouble with a 2020 amp trying to amplify an FM signal. I am using the amp for my main domestic setup and have given up on FM and use internet radio.
I have both the Lepai and a SMSL 2020 which I believe has all the mods and the both have problems with FM.
I have had this amp for about 6 months. I love the sound of the little amp. I mainly use it for MP3s. I replaced it awhile back from a failed Kinter Amp. The Kinter was a little weaker, but didn't effect my FM signal. It's got to be a way to fix this problem, unless the problem resides in the TA2020 itself.
  Reply With Quote
Old 19th November 2012, 09:19 PM   #1309
diyAudio Member
 
Join Date: Sep 2012
Default Pop suppressor

I've been running through all the mods summarized on page 60 for the older lepai. I'm relatively new to electronics but one thing I was wondering was about djnemesi's pop suppression circuit on page 45. It seems like once the RC delay builds enough voltage to pass the gate threshold on the MOSFET, current will continually pass through the transistor to ground while the amp is running. If some people are going to be hooking this up to a battery wouldn't it be more efficient to use two MOSFETs hooked up as a current inverter instead? Something like in the photo. That way one gate would always be closed.


Click the image to open in full size.

Last edited by northbynate; 19th November 2012 at 09:42 PM. Reason: Formatting picture
  Reply With Quote
Old 19th November 2012, 09:40 PM   #1310
diyAudio Member
 
sofaspud's Avatar
 
Join Date: Nov 2005
Location: San Antonio
The problem is the audio cable as antenna. The only fix I can imagine is separating the two and modding a dedicated antenna for the tuner.
__________________
It is error only, and not truth, that shrinks from enquiry. - Thomas Paine
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
New ta2020 pcb'S ArjenShenzhen Vendor's Bazaar 98 14th November 2012 11:39 AM
Ta2020 Bengali Class D 0 29th September 2007 05:28 AM
Eb-ta2020 opentop Class D 16 30th May 2005 07:42 AM


New To Site? Need Help?

All times are GMT. The time now is 06:37 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2