T-Amp problem: one channel buzzing - diyAudio
Go Back   Home > Forums > Amplifiers > Class D

Class D Switching Power Amplifiers and Power D/A conversion

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 1st November 2006, 06:32 PM   #1
lanierb is offline lanierb  United States
diyAudio Member
 
Join Date: Oct 2006
Default T-Amp problem: one channel buzzing

I have a T-Amp that worked fine for about 3 months. Then one day the left channel stops working and just makes a loud buzz. Does anyone know if this is something fixable (just for fun really)? The deal is that it works fine for about 30 seconds when powered up, then the buzzing starts. The right channel is fine.

BTW I'm pretty much a newbie so highly technical responses will be lost on me. Be gentle. Thanks!

LB
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
BUZZING PROBLEM WITH TURNTABLE-Please Help! FSHZ:42 Analogue Source 19 15th December 2008 12:51 AM
One channel softer than the other, humming and buzzing Lloyd84 Tubes / Valves 3 24th September 2007 06:45 AM
NAD 3020 Channel Problem GhettoSQ Solid State 9 19th December 2006 11:53 AM
bosoz buzzing problem cowanrg Pass Labs 29 7th August 2005 11:26 PM
Pearl Problem after R14 in one channel Mikelo Pass Labs 10 2nd March 2005 01:39 PM


New To Site? Need Help?

All times are GMT. The time now is 02:44 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2