diyAudio

diyAudio (http://www.diyaudio.com/forums/)
-   Class D (http://www.diyaudio.com/forums/class-d/)
-   -   t-amp modding trouble (http://www.diyaudio.com/forums/class-d/75348-t-amp-modding-trouble.html)

woodturner-fran 7th March 2006 07:25 AM

t-amp modding trouble
 
Hi all,


OK, I think I've done some damage to my t-amp. The plane here was to use 2 t-amps to bi-amp. First t-amp is lightly modded, reboxed and replaced the input capacitors (C3,C4) with 2.2uF audio grade ones.

I received the second t-amp today, set to work reboxing it. Eventually I got the new input capacitors on and connected (not an easy job for someone with my skills) the amp ran AOK for about 2 mins and then cut out. Opened up the box, found that the chip is getting hot if the power is turned on. If you let it cool, still no sound. No signs of burning on the board, scorch marks etc etc etc.

Have I irreparably damaged the board? Anything I should try to salvage it?

Many thanks in advance,
Fran

woodturner-fran 7th March 2006 09:24 AM

Hi again,

Also, before I go an do this again (when I can summon up the heart to do it!) do you guys think it would be OK to leave the SMT C3 and C4 in place and just add the extra capacitors. This would be easier to solder.


Fran

Pano 7th March 2006 11:47 AM

If the chip is getting hot you may have the outputs shorted to ground somehow. None of the speaker terminals can be connected to ground. Check that.

Also, it is possible that you have caused a DC offset with your inputs mods, happens all the time. There are plenty of discussions of this on the forum. Check the outputs with a volt meter. If you find more than 0.2 volts DC between + and -, then you have a problem.

woodturner-fran 7th March 2006 07:21 PM

OK, checked outputs every way I could for continuity and all checked out OK.


Then I tried what you said about the DC offset. I get about 3V on one channel and 5 on the other. The chip heats up over maybe 2 mins. Also, I only get sound on one channel, the other channel is ver faint.

Any suggestions welcome and I'll go and search the forum for this topic too.


thanks for the help,

Fran

woodturner-fran 7th March 2006 09:47 PM

OK,

I think I may have found the trouble. I reckon I've damaged the pad around C4 - right above where C4 is written. If I leave this disconnected I get a DC reading of <10mV. So obviously my desoldering of C4 has led me to this trouble, and now after all the poking, the pad beside the C4 label is gone too.

Would anyone know where else on the board I could solder the jumper to my replacement C4 cap? The trace just seems to disappear - perhaps to the other side of the board?

Thanks (again) in advance
Fran

jkeny 9th March 2006 08:18 AM

Fran,

Have you looked at Panomaniac's site - http://www.michael.mardis.com/sonic/start.html

I think this gives all the input mod options.

If you look at the schematic, even if you have destroyed the pads around C4, You could still connect a cap between end of L2 & beginning of R2.

If you can't hack it give me a shout - are you in Dublin?

John

woodturner-fran 9th March 2006 03:59 PM

Hi John,

yes, well just outside, I'm out near naas. Would you email me at woodturner-fran AT oceanfree DOT net and I'll get back to you.



Thanks,

Fran


All times are GMT. The time now is 04:44 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio


Content Relevant URLs by vBSEO 3.3.2