diyAudio

diyAudio (http://www.diyaudio.com/forums/)
-   Class D (http://www.diyaudio.com/forums/class-d/)
-   -   swCAD III simulation problem (http://www.diyaudio.com/forums/class-d/73908-swcad-iii-simulation-problem.html)

bob123 12th February 2006 09:46 PM

swCAD III simulation problem
 
2 Attachment(s)
Hi
i am having problems simulating a class d amp in swCADIII. If anyone can spot the problem i would be grateful.

The attached file has the extention .pdf but that needs to be changed to .asc for swCADIII to open it, as it is not possible to post that type of file.

Thanks
bob

powerbecker 12th February 2006 10:23 PM

2 Attachment(s)
Hello Bob,

I put some series-and parallelresistor to L1, a series-resistor to C5 and change Q1 from "NPN" to 2N 5089....
and it starts, please try it.
Regards
Heinz!

analogspiceman 13th February 2006 12:18 AM

Re: swCAD III simulation problem
 
Quote:

Originally posted by bob123

I am having problems simulating a class d amp in swCADIII [LTspice]. If anyone can spot the problem I would be grateful.

The attached file has the extension .pdf but that needs to be changed to .asc for swCADIII to open it, as it is not possible to post that type of file.

First off, it would probably be more user friendly to post .asc attachments either by zipping them or simply adding a .txt suffix (after all, they are text files).

Your simulation schematic has many problems - the driver pnp and output p-fet are upside down, Q1 neither has dc bias nor dc coupled drive from the comparator preceding it, and the input amplifier chain has questionable feedback (but you really need to fix the first two problems before beginning to worry about that).

Regards -- analogspiceman

powerbecker 13th February 2006 12:37 AM

snip:
Your simulation schematic has many problems - the driver pnp and output p-fet are upside down, Q1 neither has dc bias nor dc coupled drive from the comparator preceding it, and the input amplifier chain has questionable feedback (but you really need to fix the first two problems before beginning to worry about that).


:D , of course! But when the simulator strikes my first view is to the "simple" parts and after this small changes i see V(N001)....
and closed it without a nearer view!
Heinz!


All times are GMT. The time now is 09:06 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio


Content Relevant URLs by vBSEO 3.3.2