SI T-AMP dead? - Page 2 - diyAudio
Go Back   Home > Forums > Amplifiers > Class D

Class D Switching Power Amplifiers and Power D/A conversion

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 12th April 2005, 10:03 PM   #11
JMGJMG is offline JMGJMG  Canada
diyAudio Member
 
Join Date: Jun 2004
Location: Montreal
Thanks to ALL for the replies! Extraordinary forum!
  Reply With Quote
Old 13th April 2005, 02:58 AM   #12
toddsts is offline toddsts  United States
diyAudio Member
 
Join Date: Dec 2004
Location: Houston, TX
It will probably "work" but 400mA is less than the stock one, so you may under-power it and cause damage, don't really know for sure. A lot of folks on-line actually upgrade their power supplies to 1000mA, supposedly with positive results in sound quality. The unit should only draw as much power as it needs, so I guess the theory is that the amp occaisionally asks for more that 500mA. I haven't tried that either. My stock power supply works fine for now. A better place for that question would be headfi.org. There is a ton of info on headphones and headphone amps there and plenty of people with X-Cans too.

Todd
  Reply With Quote
Old 13th April 2005, 05:23 PM   #13
JMGJMG is offline JMGJMG  Canada
diyAudio Member
 
Join Date: Jun 2004
Location: Montreal
I bought today 12VAC / 4,5A (yes 4,5A) adapter. Seems to work fine with my Musical Fidelity X-Cans V2, tough iím not sure the sound is not a little bit rougher than with the original (MF) adapter.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dead AKG P 8E with X 8S R Bernhard Analogue Source 10 2nd April 2008 10:55 AM
dead amp ddoyle Chip Amps 20 30th July 2007 01:30 AM
Dead Amp?? Shim Solid State 12 5th June 2007 04:00 PM
Nak mb-70 dead ? MadMutt Car Audio 10 5th April 2007 03:18 AM
is my amp dead? :( torxim Car Audio 5 18th September 2004 10:37 AM


New To Site? Need Help?

All times are GMT. The time now is 07:06 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2