Go Back   Home > Forums > Amplifiers > Class D

Class D Switching Power Amplifiers and Power D/A conversion

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 18th October 2004, 11:22 PM   #1
diyAudio Member
 
Join Date: Aug 2004
Location: florida
Default STK413-20 amp chip problem

Should I attempt to replace a bad STK413-20 and a STK412 in a Kenwood KRF 8030 surround sound amp. Both chips were overdriven and has 18vdc at all the outputs, bad power supply? I am hesitant due to the surface mounted devices on the main board. If any of the surface devices smoked I dont feel its worth the troubleshooting effort to find and replace these. Any experiences out there?
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need Datasheet for STK413-220A Maxxarcade Chip Amps 2 21st June 2013 09:18 PM
chip amp for car sub Dan2 Chip Amps 8 18th November 2007 07:46 AM
12dc ssr for chip amp problem DeanP Chip Amps 2 25th October 2006 01:58 PM
Clarion car stereo problem - bad Sanyo LA4743B chip? GirchyGirchy Chip Amps 4 22nd August 2005 06:41 AM
Which chip kit? BenjaminWebber Chip Amps 1 17th August 2005 08:02 AM


New To Site? Need Help?

All times are GMT. The time now is 07:30 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2