Class D amp Working - diyAudio
Go Back   Home > Forums > Amplifiers > Class D

Class D Switching Power Amplifiers and Power D/A conversion

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 5th July 2004, 04:57 PM   #1
sonu is offline sonu  India
diyAudio Member
 
Join Date: Apr 2004
Location: maharashtra
Default Class D amp Working

Now I have my Class D Amp ready. And it is a wooopping 650W of real power to drive my 2 HUNGRY Little Subs @ 2Ohms Load. I have powered it at 70V driving P150N Mosfets, and the amp is quite cool even at high power levels. As I have used it for my subs, I have used a active Linkwitz crossover, and it has a real base.
I have'nt used any feedback but have made short circuit & Overload circuit which works perfect.
There is only one problem that i have there is a 150Kz sine wave of 3V PP showing on my oscilloscope on the output, with no input to the amp, is it due to the dead time between the pulses.
I have used a Filter inductor of 550uH with .68uf Caps, which is not a perfect calculation.
Can anybody guide me to get a spread sheet for filter Calculation.

Regards,
Sonu.
  Reply With Quote
Old 5th July 2004, 05:26 PM   #2
diyAudio Member
 
Join Date: Jul 2004
Location: italy
schematics please!!!!!!!!!!!!!!
  Reply With Quote
Old 3rd August 2004, 10:23 PM   #3
diyAudio Member
 
Join Date: Jan 2004
Location: Romania
Send a message via Yahoo to sorinsistem
schematics please!!!!
__________________
PERFECT SOUND
  Reply With Quote
Old 4th August 2004, 06:50 AM   #4
diyAudio Member
 
Join Date: May 2002
Location: Switzerland
Quote:
There is only one problem that i have there is a 150Kz sine wave of 3V PP showing on my oscilloscope on the output, with no input to the amp, is it due to the dead time between the pulses.
Isn't this simply the residual of the switching frequency ? In this case I wouldn't care about it for sub use unless you use very long cables (and you might therefore be a source of RFI).

Regards

Charles
  Reply With Quote
Old 5th August 2004, 02:13 PM   #5
sonu is offline sonu  India
diyAudio Member
 
Join Date: Apr 2004
Location: maharashtra
It was a problem with LC Filter, now it is solved,
I have also made 1500W RMS Amp to 2 Ohms Load working Perfectly OK, little heating in the Inductors.

Only thing i am concerned is still i have to perfectly design the LC Filter. I am not getting proper info on Butterworth Filter design.

Regards,
Sonu.
  Reply With Quote
Old 5th August 2004, 02:35 PM   #6
diyAudio Member
 
Join Date: May 2002
Location: Switzerland
Quote:
Only thing i am concerned is still i have to perfectly design the LC Filter. I am not getting proper info on Butterworth Filter design.
What do you mean by "perfectly" ?

Do you want to get rid of ALL the ripple ?

If so, I wouldn't recommend doing it ! While it was always recommended to suppress the carrier as much as possible in older texts, there is now a general agreement that you sacrifice less audio quality when using less steeper filters with higher cutoff frequencies.

Regards

Charles
  Reply With Quote
Old 5th August 2004, 06:14 PM   #7
palesha is offline palesha  India
diyAudio Member
 
Join Date: Nov 2001
Location: Pune India
Congrates Sonu.
Changla vatla. Aaplya manasani ase kahi keleki khup changla vatatay. Mu punyacha aahe. He lok swatala khup shani samajtat. Software nanter electronics madhe aaplya lokani ase kahi keleki khup bare vaatle. Dhanyavad,
Mahendra Palesha
  Reply With Quote
Old 13th August 2004, 04:10 PM   #8
sonu is offline sonu  India
diyAudio Member
 
Join Date: Apr 2004
Location: maharashtra
Hi palesha,
mi pan punecha,
where do u stay in pune, any contact no. n what do you do, Sorry to reply late, I am not a regular user of net.

Regards,
Sonu
  Reply With Quote
Old 13th August 2004, 04:56 PM   #9
palesha is offline palesha  India
diyAudio Member
 
Join Date: Nov 2001
Location: Pune India
Dear Sonu,
I hv TV antenna booster factory in Pune. U can call me on 26355702. I am in Bhawani Peth, Pune. What about u?
Mahendra Palesha
  Reply With Quote
Old 14th August 2004, 03:49 AM   #10
diyAudio Member
 
Join Date: Sep 2003
Location: Illinois
sonu, we'd still like to see a schematic and pcb...

thanks
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
I got My class D working !! stocktrader200 Class D 16 31st July 2008 09:14 AM
20k watt amp a document or a working class H hienrich Solid State 15 2nd September 2006 03:45 AM
Class Q will be working next year! destroyer X Everything Else 14 1st January 2005 02:08 PM
Why do so few designs use opamps working in class A? fmak Solid State 19 23rd May 2002 03:25 AM


New To Site? Need Help?

All times are GMT. The time now is 09:17 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2