SMPS efficency issues... - Page 4 - diyAudio
Go Back   Home > Forums > Amplifiers > Class D

Class D Switching Power Amplifiers and Power D/A conversion

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 25th May 2004, 07:45 PM   #31
diyAudio Member
 
Join Date: Dec 2003
Location: Munich
@FDM:
Great, if you want my files just send me your mail adress.

To get my simulation running, please keep the following thing in mind.
1.
The standard Ron for the switches is 1 Ohm, don't forget to adjust them.
2.
Default values in the options of the simualtion profile will not work,
because of convergence issues!
Changing the options for the simulation routine itself is sometimes critical as nearly nobody is able to foresee all the effects, which can be caused.... well, at least I am not a "GOD of Numeric Math" ....
But a very good way to get rid of 90% of all convergence issues is to allow a higher number of iterations before the simulation is aborted.
In the options of the simulation profile you will find a value which is called "ITL4". The default value here is 10 iterations, as most simualtions show very fast convergence. But especially for switching applications the SPICE algorithms often need more iterations.
If you set this value to 100, then this simulation should work.

May be my files, which I can send to you, are already including the increased ITL4 setting for this specific project...
But the Ron value of the Sbreak is given in the Sbreak.lib and you should have look to this.

Good Luck
Markus
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
8" high efficency woofers - NEED HELP Miha Multi-Way 9 28th February 2007 01:43 PM
Efficency Confussion Mutley666 Multi-Way 10 25th May 2005 02:15 AM
Passive crossover (in)efficency? Pbassred Multi-Way 6 12th May 2005 12:34 AM
Few SMPS issues arcom Car Audio 9 30th January 2005 12:55 PM


New To Site? Need Help?

All times are GMT. The time now is 09:58 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2