Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Class D Switching Power Amplifiers and Power D/A conversion

SANWU TPA3116 + CSR8635 Bluetooth 4.0 - Noise Fix
SANWU TPA3116 + CSR8635 Bluetooth 4.0 - Noise Fix
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 9th May 2018, 07:56 AM   #211
krlskndl is offline krlskndl  Spain
diyAudio Member
 
Join Date: May 2018
Default About AUX input commutation to avoid POP noise

Hi guys!
I'm new in this forum. In first place let me thank you for all your valuable work and information.
I'm working on a project with a module using the CRS8635 and have the same problem about the pop noise when audio streaming stops.
I reached this forum and found the activation of the AUX input as a very clever and smart solution.
I've tried it with, unfortunately, no success. It seems that the amplifier is powered off after about 3 seconds after the A2DP stream stops an turned ON again (for the AUX input) after about 120 ms, as you can see in this capture:
CorteAudioBT.jpg
So, the "pop" noise due to the negative edge in the DC voltage is still there.
I think that the best sollution woud be to find the way to avoid the powering off of the output amplifier of the CSR chip. I suppose it should be possible with any of the hundreds of PSKEYS, but wich one???
Does anyboy have any clue about it?
Thank you very much to all of you and, please, sorry for my english!
  Reply With Quote
Old 11th May 2018, 11:39 AM   #212
mraas is offline mraas
diyAudio Member
 
Join Date: Apr 2018
Hi Guys,


first time poster, long time lurker.


after 5 weeks of waiting I finally received this. the BT 4.2 aptx low latency version : SANWU(R) 50W+50W TPA3116 HIFI-Class Wireless Bluetooth 4.2 Amplifier Support APTX Low Delay Sale - Banggood.com


tried it, sounds really good, but also BT hiss... haven't tried the aux in jack yet.
So, before examining the Diff2SE stage I'd post some pictures here:


also todo: figure out the break-out connection on the front, I know already a couple of the pins lead to the bottom of the CSR BT module.


Click the image to open in full size.


Click the image to open in full size.


Click the image to open in full size.


Click the image to open in full size.


Click the image to open in full size.


Click the image to open in full size.
  Reply With Quote
Old 10th June 2018, 07:00 PM   #213
AdidasNMD is offline AdidasNMD
diyAudio Member
 
Join Date: Jun 2018
Hi,

This isn't a question about the sound quality (yet), but with some of the technical knowledge on display some have on here you may be able to help.

I've bought this board. Click the image to open in full size.

I needed the one with the input jack and bluetooth and unfortunately I got the one with bluetooth only.




Rather than get rid of the board I thought I'd try soldering a jack to the pins itself. Would they need to be connected to the TPA3116 chip, pins INNB, INPB, INNA, INPA?
Or would it be the LINE_AN/AP and BN, BP on the bluetooth module?

Would be grateful for some input on this.

Last edited by AdidasNMD; 10th June 2018 at 07:19 PM.
  Reply With Quote
Old 19th July 2018, 08:00 AM   #214
FantomXR is offline FantomXR
diyAudio Member
 
Join Date: Nov 2013
Hey people,

I need your help... I tried everything and I can not get it working.

See attachment for the board, that I have.
It has a CSR8635 on board.

As you can see it has solderpads underneath, which should be SPI_EN, GND, VBAT, MOSI, CLK, CSB and MISO.
I connected MOSI, CLK, CSB and MISO to my FT232RL module, which I also attached.

I also connected VBAT to 3V3 to FT232RL and 1V8 from CSR to the VCCIO-pin of the FT232RL.

And here is the problem: As far as I know SPI_EN should be pulled high for programming. But as soon as I connect a 10k between SPI_EN and 1V8 (or 3V3), the CSR won't boot anymore... at least the LEDs are not working. Also I can not get BlueSuite to recognize the CSR. Of course I followed all steps from GitHub csr-spi-ftdi.

What do I overlook?!

Thanks!!
Attached Images
File Type: jpg 71PsxLFRmEL._SL1500_.jpg (234.6 KB, 11 views)
File Type: jpg 7177F9o6SNL._SL1000_.jpg (152.4 KB, 12 views)
  Reply With Quote
Old 19th July 2018, 10:33 AM   #215
doctormord is offline doctormord  Germany
diyAudio Member
 
doctormord's Avatar
 
Join Date: Oct 2007
The 1V8 is derived from the CSR itself, no need to connect to the RL. Does the RL do work with 1V8 signal levels at all?
  Reply With Quote
Old 19th July 2018, 10:37 AM   #216
FantomXR is offline FantomXR
diyAudio Member
 
Join Date: Nov 2013
I thought it works with 1V8 signal level. What would you suggest?
  Reply With Quote
Old 19th July 2018, 09:44 PM   #217
mraas is offline mraas
diyAudio Member
 
Join Date: Apr 2018
hi guys…

quick question about the bluetooth board on these amps…


I've desoldered mine and took it of because I'd like to use the amp just with a line input for my application..

as the bluetooth board has aptx I'd like to use it for a ifferent application..
so, powered connected vbat and gnd and the line outs, but when applying the appropriate voltage (4.2v) it doesn't start up.. (eg. not found thourgh cell Phone bluetooth).. I've not conneted any leds yet.


Anyone knows if I need to connect something different first before the board powers up? (i know I've desoldered more than the 6 leads I've soldered on now, buy mainly pinouts to the connector on the front, see a couple of posts ago)


thanks.
  Reply With Quote
Old 23rd July 2018, 03:31 PM   #218
Ratskie is offline Ratskie
diyAudio Member
 
Join Date: Jul 2018
Quote:
Originally Posted by ivicanikolic034 View Post
Thank you very much!!!
I did it, and it works! Noise is no more present!

But i have a feeling that speakers are quieter now, volume is lower i think... Is this normal?
I got this Bluetooth amplifier thesame.
When I power on beep on speaker, I connect my Android. Connected, and play some music, after a several seconds no sound but still Bluetooth connection remain and I can control the bottom.
  Reply With Quote

Reply


SANWU TPA3116 + CSR8635 Bluetooth 4.0 - Noise FixHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
cheap TPA3116 2.1 amplifier with bluetooth x265 Class D 4 5th December 2017 03:41 PM
$30 tpa3116; bluetooth; speaker protection; eq Any good? nige838 Class D 42 15th September 2016 01:08 PM
TPA3116 Bluetooth 4.0 2x50W Amp onehundred Class D 31 3rd January 2016 06:50 AM
Defective TPA3116 with bluetooth onni Class D 6 8th October 2015 08:54 PM
FS: TPA3116 in housing with bluetooth mravlca Swap Meet 2 27th July 2015 11:09 AM


New To Site? Need Help?

All times are GMT. The time now is 07:09 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.00%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Copyright ©1999-2018 diyAudio
Wiki