hypex PSC2.400 just don't play - diyAudio
Go Back   Home > Forums > Amplifiers > Class D
Home Forums Rules Articles diyAudio Store Gallery Wiki Blogs Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Class D Switching Power Amplifiers and Power D/A conversion

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 27th December 2015, 09:12 AM   #1
diyAudio Member
 
Join Date: Mar 2011
Location: Bucharest
Default hypex PSC2.400 just don't play

Hello, I've bought 4 plates psc2.400, without D.
First I've thought that they do not play because at firts use I could not select the imput, it was grey in software. Than I started the software without the conection, an imidately that I've conected the software, the first page changeg by disapearing the imput selection. After that I did the math and I came to the conclusion that since these plates have only one imput, it obviously I can't change the imput so this is not the reason they do not play.

First I've tried with the speakers conected, and they did not play, than I've disconected the speakers, than design the crossover and than conected the speakers. In the first attept one plate did played till I've tunet up the crossover, and even though it was a little ajustment, when the cross was downloading in the plate, I heared a litle bum and than the music stoped and a noise started and now none of the plates run music.

At one of the I tried firmware update from the cd that comes with the plates, and during update it stoped and the computer crashed, after 10 minutes I restarted the computer and this plate when conected it is not recognised anymore and non of it's led do not start.

I've emailed to suport at hypex an it is 5-6 days and still no answer.

The speakers are sbacoustics sb23nrx -8, than Ive put eminence alpha 8a, the tweeters are form scanspeak.

Any ideas of how I reset the plate that "died" and how do I start the rest of the plates?

I have 2 A2.100d and I am very fond of them, they do the work in any conditions with no faults.

Thanks
Attached Images
File Type: jpg 4133.jpg (1,002.2 KB, 59 views)
File Type: jpg IMG_20151222_230127.jpg (1,012.9 KB, 58 views)

Last edited by terteliu; 27th December 2015 at 09:15 AM.
  Reply With Quote
Old 27th December 2015, 11:32 AM   #2
ds23man is offline ds23man  Netherlands
diyAudio Member
 
ds23man's Avatar
 
Join Date: Oct 2006
Download the new Filterdesigner first:

Hypex DSP module(s)

Use the latest firmware as published on the Hypex website.

Do not try to connect more than one plate at the same time on your computer!
  Reply With Quote
Old 28th December 2015, 08:10 AM   #3
diyAudio Member
 
Join Date: Mar 2011
Location: Bucharest
I did used the firmware from the site, and it was only one plate at the same time, I have only one usb cable.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How hot is your Hypex PSC2.400 TNT Class D 17 1st September 2015 08:12 PM
Hypex PSC2.400(D) - Auto On, Standby Power Eunegis Class D 1 30th September 2014 10:18 PM
Hypex PSC2.400 - PEQ and shelving filters otto88 Class D 1 14th August 2013 07:44 PM
Hiss in Hypex PSC2.400 atledreier Class D 43 14th January 2013 11:37 PM
WTB: Hypex PSC2.400d OllBoll Swap Meet 1 19th November 2012 03:39 PM


New To Site? Need Help?

All times are GMT. The time now is 02:03 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Copyright 1999-2016 diyAudio

Content Relevant URLs by vBSEO 3.3.2
Wiki