Behringer Europower PMP 530M - diyAudio
Go Back   Home > Forums > Amplifiers > Class D
Home Forums Rules Articles diyAudio Store Gallery Wiki Blogs Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Class D Switching Power Amplifiers and Power D/A conversion

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 22nd December 2015, 08:38 PM   #1
diyAudio Member
 
Join Date: Sep 2012
Default Behringer Europower PMP 530M

I have 3 Behringer Europower PMP 530M on my bench . They all have shorts in them . I did comparison checks between all the major componits , IGBTs & Mosfets BJTs and diodes on all boards. They check fine in circuit. Maybe I need to pull them out compleatly and check them that way. I don't have a schematic and Behringer wont help at all. I think its compleatly stupid that they don't help us techs at all. Any help on these would be thankfull.
  Reply With Quote
Old 22nd December 2015, 10:26 PM   #2
diyAudio Member
 
JonSnell Electronic's Avatar
 
Join Date: Dec 2012
Location: The Jurassic Coast, England. GB
Send a message via Skype™ to JonSnell Electronic
The manuals are available only to their service agents. They are very basic. What shorts have you got? If a FET is short it reads short.
__________________
Support for Flying Mole Class D, Valve Equipment and designs both new and old. www.jonsnell.co.uk
  Reply With Quote
Old 23rd December 2015, 09:04 PM   #3
diyAudio Member
 
Join Date: Jan 2010
I found schematics of some similar item in my database - hope this helps
Attached Files
File Type: zip BehringerEuroPowerEP2500.pdf.zip (212.4 KB, 34 views)
  Reply With Quote
Old 24th December 2015, 05:46 PM   #4
diyAudio Member
 
Join Date: Sep 2012
To Jon Snell. so far I've checked all componets for shorts . I found a couple of diodes that show a dead short that are associated the power supply. I will pull those next and check them . I also pulled out the final Mosfets or IGBTs and checked them they were fine. As some componets you have to pull out of circuit compleatlly to get an accurate reading.
  Reply With Quote
Old 24th December 2015, 05:48 PM   #5
diyAudio Member
 
Join Date: Sep 2012
To voltwide , I'm sure that I can use at least part of this schematic to troubleshoot my problem. Thanks.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Behringer PMP-1000 Mixer Pow.er Supply info Teknofix Instruments and Amps 5 9th September 2015 12:02 AM
behringer europower 1500 gerettiluca88 Chip Amps 0 19th May 2015 10:07 AM
Behringer's Europower EPQ450 youknowyou Solid State 0 20th December 2014 11:44 PM
Behringer PMP Schematics Zero Cool Instruments and Amps 14 22nd August 2013 10:29 PM
Behringer Europower EP1500 sterjess Solid State 1 27th March 2010 08:41 AM


New To Site? Need Help?

All times are GMT. The time now is 10:46 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Copyright 1999-2016 diyAudio

Content Relevant URLs by vBSEO 3.3.2
Wiki