soundstream xxx6500d no relay - diyAudio
Go Back   Home > Forums > Amplifiers > Class D
Home Forums Rules Articles diyAudio Store Gallery Wiki Blogs Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Class D Switching Power Amplifiers and Power D/A conversion

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 7th October 2015, 11:43 PM   #1
diyAudio Member
 
Join Date: Dec 2009
Default soundstream xxx6500d no relay

hi i am working on a soundstream xxx6500d and the relay does not engage.

If i connect the speaker before the relay i get clean audio.
Does anyone have a schematic for this amp.

Any help will be much appreciated
  Reply With Quote
Old 8th October 2015, 12:44 AM   #2
DjLeco is offline DjLeco  Romania
diyAudio Member
 
Join Date: Oct 2006
Location: Bucharest, Romania
Send a message via Skype™ to DjLeco
The relais doesn't do the "engage click"?

If it do, and no output, the relais contacts can be dead.
Attached Images
File Type: jpg Untitled.jpg (257.3 KB, 65 views)

Last edited by DjLeco; 8th October 2015 at 12:50 AM.
  Reply With Quote
Old 8th October 2015, 03:18 AM   #3
diyAudio Member
 
Join Date: Dec 2009
Thanks for the reply.
There is no clicking of the relay.I have traced it back to pin 4 on the driver card but i dont know where to go from there.
  Reply With Quote
Old 8th October 2015, 09:58 AM   #4
DjLeco is offline DjLeco  Romania
diyAudio Member
 
Join Date: Oct 2006
Location: Bucharest, Romania
Send a message via Skype™ to DjLeco
Make a shortcircuit between Base ans Emitter of Q3 (red circled one in left side).

If engages check other components around it, if not engages, R11 (10 ohms) could be open circuit, and maybe diode DP5 could be shorted.

Make another test, with volume set to minimum (no signal on input), check with one DC multimeter if before relais (where U got clean audio), if is present any continuous DC voltage between output and GND.

Write here what U have measured.

Or simpler, again with no signal on input, if connect speaker and you have some DC there the voicecoil must go out or in speaker chassis.
  Reply With Quote
Old 8th October 2015, 02:42 PM   #5
diyAudio Member
 
Join Date: Dec 2009
If i short the collector and emitter of q3(d600) the relay engages...there is no movement of the speaker cone.If i measure it with reference to speaker ground i get 0.015 volts dc.
  Reply With Quote
Old 8th October 2015, 02:56 PM   #6
diyAudio Member
 
JonSnell Electronic's Avatar
 
Join Date: Dec 2012
Location: The Jurassic Coast, England. GB
Send a message via Skype™ to JonSnell Electronic
If the remote is faulty or stuck in mute, remove (temporarily) D7 to override the mute function. Most stay muted until signal is received.
__________________
Support for Flying Mole Class D, PMC DS-001 (Hypex),Valve Equipment and designs both new and old. www.jonsnell.co.uk
  Reply With Quote
Old 8th October 2015, 04:58 PM   #7
DjLeco is offline DjLeco  Romania
diyAudio Member
 
Join Date: Oct 2006
Location: Bucharest, Romania
Send a message via Skype™ to DjLeco
Emmiter to collector, sorry for mistake.
  Reply With Quote
Old 8th October 2015, 06:59 PM   #8
diyAudio Member
 
Join Date: Dec 2009
Removed d7 and still no relay.
  Reply With Quote
Old 9th October 2015, 03:12 AM   #9
diyAudio Member
 
Join Date: Dec 2009
I just pulled and tested everything as per schematic above.Everything tested ok.

Anything else i should be looking at?
  Reply With Quote
Old 9th October 2015, 04:32 AM   #10
diyAudio Member
 
Join Date: Nov 2008
Location: Victoria,TX
Blog Entries: 1
Hi,
Check the bases voltage of Q3 and Q5. It should be positive to enable the relay.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Soundstream D200 Relay Substitute Help dodgerblue Car Audio 2 17th August 2011 09:35 PM
Soundstream USA204 razirafi Car Audio 28 27th September 2007 07:30 AM
Soundstream shaolinfox30 Car Audio 1 24th July 2007 10:03 AM
soundstream 6.0 ben04srt Car Audio 10 11th March 2007 05:56 AM
Soundstream? thylantyr Pass Labs 6 10th November 2006 09:35 PM


New To Site? Need Help?

All times are GMT. The time now is 09:10 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Copyright 1999-2016 diyAudio

Content Relevant URLs by vBSEO 3.3.2
Wiki