Ucd 400 AD repair advice - diyAudio
Go Back   Home > Forums > Amplifiers > Class D

Class D Switching Power Amplifiers and Power D/A conversion

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 18th August 2015, 02:48 PM   #1
Jaffrie is offline Jaffrie  Indonesia
diyAudio Member
 
Join Date: Oct 2013
Default Ucd 400 AD repair advice

Hi reauys,

Was wondering if anyone can advice . I was checking voltage
with my DVM & the probe accidentally touch the BDX 34 which cause
a little spark. No sound after this incident. I assume that I must
have fried the BDX & the AD op amp. Replaced both BDX's & AD op
amp but still no sound. Would appreciate if anyone can advice on
what else to check or replace.

Thanks in advance
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Advice slight Ucd 400 issue Jaffrie Class D 0 3rd June 2015 03:28 AM
hypex ucd 400 ad Jaffrie Class D 2 31st May 2015 07:08 AM
UCD 400 AD 2 sets monoblock ijscobar Swap Meet 4 9th October 2012 08:07 AM
UcD 400 repair?? icewall Class D 1 17th November 2006 09:31 PM
Hypex UcD 400 AD amplifier module for sale mp006ltk Swap Meet 9 15th November 2006 02:56 PM


New To Site? Need Help?

All times are GMT. The time now is 08:45 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.
Copyright 1999-2015 diyAudio

Content Relevant URLs by vBSEO 3.3.2