Right Channel shuts off - on two new amps - diyAudio
Go Back   Home > Forums > Amplifiers > Class D

Class D Switching Power Amplifiers and Power D/A conversion

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 27th December 2014, 04:19 PM   #1
diyAudio Member
 
Join Date: Dec 2014
Default Right Channel shuts off - on two new amps

Gents,

Needs some advice. Iím running a Sony DSX-210 HU, with a Power Acoustik RZ4.2000 powering two Infinity Kappa 62.11 (2 ohm) 6.5 speakers on a motorcycle. I was using a RF PBR300X2 with no issues but want to add 2 more speakers so swapped out to the Power Acoustik based on some review from other harley owners.

A few weeks ago I wired the PA, and after a few minutes of pushing the volume my right front channel shut off. I swapped RCAís, speaker wire and no-luck so I sent the amp back to Sonic. A few days ago I got a new amp and the same thing happened. I bought new RCAís, new speaker wire, tried both front and rear RCAís from the HU, tried High level inputs and with either front or rear channels on the amp, it shuts down the right channel when pushed. (protection light does not come on).

I have my gains set to 11 oíclock (about 1/4 turned up). Iím running 4 gauge power to the battery. Had 4 gauge to the frame, but then ran a 10 gauge wire to the battery as well. Iíve tried every way to connect this and no luck...the right channel shuts off. I had no issues with the PBR.

Did I really get TWO bad amps, or am I doing something wrong here?

Thanks for the help. Im stumped.
  Reply With Quote
Old 28th December 2014, 01:55 AM   #2
diyAudio Member
 
Join Date: Jul 2011
try switching speakers? sounds like it could be a damaged speaker thats presenting a really low resistance to the amp and putting it into protect.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
TSE shuts down after a few Min. pbkrag Tubelab 7 29th March 2014 12:05 AM
Radio shuts off when light are turned on coconuthorse Car Audio 8 11th May 2013 03:11 PM
Holmimpulse shuts down after starup percy Multi-Way 0 26th May 2012 04:25 PM
ML #23 shuts itself off after 5 seconds. Howard Lan Power Supplies 5 8th December 2007 08:17 AM
SMPS for diy audio amps and multi-channel diy amps (and their power supplies) tlparker Solid State 18 31st August 2006 11:39 AM


New To Site? Need Help?

All times are GMT. The time now is 07:02 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.
Copyright ©1999-2015 diyAudio

Content Relevant URLs by vBSEO 3.3.2