Lepai amp - light comes on but no sound - diyAudio
Go Back   Home > Forums > Amplifiers > Class D

Class D Switching Power Amplifiers and Power D/A conversion

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 29th September 2014, 10:18 AM   #1
SHeslam is offline SHeslam  United Kingdom
diyAudio Member
 
Join Date: Feb 2014
Location: Cambridge
Default Lepai amp - light comes on but no sound

Hi all
I've got a Lepai 2020A+ for a boombox that I've made. I've never had any problems with it but now when I try to power it with my motorcycle lead acid battery, the light on the amp comes on but no sound comes out... Yet when I tried plugging it into the mains and it all works fine.
Any ideas?
Many thanks
  Reply With Quote
Old 29th September 2014, 10:49 AM   #2
Bone is offline Bone  United Kingdom
diyAudio Member
 
Join Date: Jun 2004
Location: Dorset, UK
What is the voltage from your battery? If its too high then there is overvoltage protection which switches the amplifier off.
  Reply With Quote
Old 29th September 2014, 10:58 AM   #3
SHeslam is offline SHeslam  United Kingdom
diyAudio Member
 
Join Date: Feb 2014
Location: Cambridge
Thanks for the reply
I'm using a 12V battery which has worked fine in the past so I don't think that's the problem
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Lepai 2020 - no sound at all! Crypto Class D 7 11th June 2014 01:18 PM
Problem with Lepai Amp - uneven sound on speakers david11 Class D 7 16th October 2013 06:33 PM
Lepai TA2020 Clicking Sound papayoyo Class D 11 7th December 2012 01:16 AM
No sound from Lepai TA2020, no current draw SecretChimp Class D 2 14th September 2011 09:02 PM
No sound from Lepai / TA2020 ggaahh Class D 2 12th June 2011 03:16 PM


New To Site? Need Help?

All times are GMT. The time now is 09:41 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2