Go Back   Home > Forums > Amplifiers > Class D

Class D Switching Power Amplifiers and Power D/A conversion

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 16th February 2014, 12:55 AM   #1
diyAudio Member
 
Join Date: Feb 2014
Location: ohio
Default memphis mcd500...dead

IM new so hopefully i don't make myself look really bad lol.Anyhow this amp does nothing.I have 12 volts at the center leg of the power supply transistors.Have power entering the vertical board where the tl494 lies but no voltage on any pin of the tl494.Going to try to upload pic if it matters.There's a missing capacitor....My fault lol...misdiagnosis on my part
Thanks,Jon
Attached Images
File Type: jpg 20140215_204646.jpg (538.8 KB, 26 views)
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dead Dead Laser Pickups - why not replacing the Diode only? Salar Digital Source 20 24th July 2013 09:34 PM
Memphis PR400 seankane Car Audio 13 30th November 2011 02:57 AM
memphis 1500d timwebb Car Audio 19 16th January 2011 02:21 AM
memphis 1000 mike49504 Car Audio 43 13th January 2010 04:34 PM
Memphis...? hooverjr10 Subwoofers 0 14th December 2007 03:16 AM


New To Site? Need Help?

All times are GMT. The time now is 06:00 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2