Cx 1200 D stuck in power protect mode. - diyAudio
Go Back   Home > Forums > Amplifiers > Class D

Class D Switching Power Amplifiers and Power D/A conversion

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 15th October 2013, 09:54 PM   #1
diyAudio Member
 
Join Date: Oct 2013
Location: Austin
Default Cx 1200 D stuck in power protect mode.

I have 2 amps stuck in power protect mode. This happend while trying out different subs. I have 3 of these amps. The other amp never went into protect mode because there was no sub hooked up to it at the same time. I have a extra battery which leads to Pyle millennia capacitor which powers the amps which power their own sub. Any help????
Attached Images
File Type: jpg image.jpg (237.6 KB, 87 views)
  Reply With Quote
Old 15th October 2013, 11:05 PM   #2
diyAudio Member
 
Join Date: Dec 2012
Location: The Jurassic Coast, England. GB
Send a message via Skype™ to JonSnell Electronic
Have you looked at the square wave wave form for equal pulses, up and down spacing?
__________________
www.flyingmole.co.uk For World Wide support for Flying Mole, Class D, Refurbishment and Repairs. www.jonsnell.co.uk
  Reply With Quote
Old 16th October 2013, 01:01 AM   #3
diyAudio Member
 
Join Date: Oct 2013
Location: Austin
I have no tools to check the wave pattern. When I touch the positive side of speaker output and remote together the speaker pushes up. I'm new to this and the one person who american bass referred me to said this amp is too old for him . He told me to retire the amps and buy some from him. I refuse to believe they are too old.
  Reply With Quote
Old 16th October 2013, 02:52 PM   #4
diyAudio Member
 
Join Date: Oct 2013
Location: Austin
Ok I have read up on perry babin and his website. He also
Helped another guy on this site with the same model amp. I will get get wave patterns in the near future. And is it that hard to find 5 ring resistors. On Perry's site he mentions that those resistors are rare?
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
American Bass CX-1200-D mike49504 Car Audio 14 16th October 2013 03:16 PM
Audison Millenium Power 4 protect mode benwake Car Audio 4 24th January 2012 02:50 PM
kicker kx800.4 stuck in protect mode ivkata Car Audio 4 15th December 2011 01:28 AM
Power acoustik lt1920-2 amp stuck in protect mode psu ishue ivkata Car Audio 15 14th December 2010 02:29 AM
Nikko Power Amplifier Alpha II Stuck On Protect Jkohuts Solid State 12 28th March 2010 04:45 PM


New To Site? Need Help?

All times are GMT. The time now is 01:43 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2