SMSL SA-S1 low volume noise - diyAudio
Go Back   Home > Forums > Amplifiers > Class D

Class D Switching Power Amplifiers and Power D/A conversion

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 27th February 2013, 08:49 PM   #1
morglo is offline morglo  Sweden
diyAudio Member
 
Join Date: Jun 2005
Location: Stockholm
Default SMSL SA-S1 low volume noise

Hello all.

I just received a SMSL SA-S1 from MarcMarts Ebay store. A neat little package that looks and sounds great, aside from one disturbing issue:
It has an audible noise (so called pink noise) on low volumes up to 12 o'clock volume knob position. It recedes on max volume, but is still there. This phenomenon remains with and without rca cables attached to a music source. I have tried 2 different switch mode power supplies. One 12V 1,5 A from an Audio Pro portable ipod dock. It should be of good quality. The other one a rather expensive multi voltage power supply Switchat nätaggregat - 72*W > Ställbar utspänning | Kjell.com

My first step will be to give the seller a chance to correct this. If this fails, I would welcome suggestions as how to fix this issue myself. Could this for example be resolved with some kind of filtering, a cap on the dc input?

Best regards.
  Reply With Quote
Old 28th February 2013, 08:29 PM   #2
morglo is offline morglo  Sweden
diyAudio Member
 
Join Date: Jun 2005
Location: Stockholm
So I tried to contact their support, and I got answers!

"Dear friend,
Good day. Thanks very much for your message.
We feel sorry for the late reply.It takes us some time to contact with our professional colleagues.And he suggests that you could have a try to break the AUDIO IN signal wires behind the amplifier,then open the amplifier and turn the sound to maximum.After doing that,if there's noise insist,please don't hesitate to tell us.Thanks~!

If there is any question or problem, please feel free to contact us.
Thanks&Best regards,
Marcmart"

A bad case of google translate it seems. My interpretation was that I should disconnect the Audio in, turn the amp on and crank the volume up to max. Of course, this would not help.

If I was to take them on their words I even could try to open the case. I will avoid this as that would mean breaking the warranty seal. I am awaiting their next reply.
  Reply With Quote
Old 2nd March 2013, 10:30 PM   #3
diyAudio Member
 
nigelwright7557's Avatar
 
Join Date: Apr 2008
Location: Carlisle, England
Could be too much gain in the amp amplifying noise.
Try turning down the gain.

If all else fails you could try an RC filter on the input.
f=1 / 2 pi R C
__________________
PCBCAD50 software. http://www.murtonpikesystems.co.uk
  Reply With Quote
Old 3rd March 2013, 12:27 AM   #4
morglo is offline morglo  Sweden
diyAudio Member
 
Join Date: Jun 2005
Location: Stockholm
Hi Nigel. Thanks for the suggestions.

I suppose the only way to turn down the gain without opening the case and thereby voiding warranty is to turn the volume counter clockwise. Oddly enough it has the most noise on the lowest volume setting, from 7 o'clock to 11 o'clock. When I crank it up, it is dead silent.

The RC filter formula was a bit above my engineering skills But I guess F is a frequency cut off point, R a resistance value and C a capacitor value. Out of curiosity, how will this filter work? Will it attenuate the noise without sacrificing the audible frequency spectra?

Good news is that MarcMart has offered to ship me a replacement unit
  Reply With Quote
Old 3rd March 2013, 12:32 AM   #5
diyAudio Member
 
nigelwright7557's Avatar
 
Join Date: Apr 2008
Location: Carlisle, England
Set the filter frequency for around 30KHz.
Put a resistor in series with the input then after the resistor put the capacitor to ground.
This will filter out RF and noise above 30KHz.

This filter is commonly used on the front end of amplifiers.

The input impedance of the amp is important when determining the RC values.
__________________
PCBCAD50 software. http://www.murtonpikesystems.co.uk

Last edited by nigelwright7557; 3rd March 2013 at 12:43 AM.
  Reply With Quote
Old 15th March 2013, 05:01 PM   #6
diyAudio Member
 
Join Date: Mar 2013
resurected this as i'm having the same problem with my new sa s1, i have never worked on an amp board before and i must admit i am still learning the basics of electronics, could anyone explain installing the filter in laymans terms ?
  Reply With Quote
Old 19th March 2013, 10:39 AM   #7
diyAudio Member
 
Join Date: Mar 2013
after contacting marc mart with details of the problem. they replied saying to replace the capacitor shown in the pic with a red arrow with a 104 (0.1uf) capacitor as i said previously i've never worked on a pcb before so i am making them promise to replace it if i fudge the job up before i go ahead and open the thing up. any advice on this would be greatly appreaciated
Click the image to open in full size.
  Reply With Quote
Old 23rd March 2013, 06:42 PM   #8
diyAudio Member
 
Join Date: Mar 2013
right i have it sorted on my amp. i was told by marc mart to replace the capacitor shown in the picture (red arrow)View image: N8 RN1 CBPZ1 MLK[ 46 Y [7 BM with a 104 0.1 uf capacitor x50 pcs 100nf 0.1uf (104) 25v ceramic disk capacitors 1st class post from uk | eBay. i did that with the help of a friend and it worked woop woop no more pink noise and a lovely sounding amp.
  Reply With Quote
Old 8th April 2013, 09:56 PM   #9
morglo is offline morglo  Sweden
diyAudio Member
 
Join Date: Jun 2005
Location: Stockholm
Default Got my replacement

So, I finally got my replacement SMSL SA S1 amplifier. As I tested it i was initially glad that it was dead silent. Then came the cold shower. The bass response was horribly weak and somewhat distorted. I was nearly howling with rage and about to throw the junk through my window but got to my senses and started troubleshooting.
I switched between different speakers, and compared the sound from sources such as laptops and smartphones. I tried different rooms and setups, and even compared the sound to my trusty old Denon 2105.
The reason for the bad sound in my first test was because of a Dolby sound effect feature on my laptop that was on by default. A truly retarded equalization. I recently reinstalled this Lenovo laptop of mine and missed to remove the soundprocessing. I also like to think that the sound somehow got better by warming up the amp. Anyhow, this SMSL amp is well worth the money, despite the fact that I got a faulty amp to begin with. It keeps up fairly well with my Denon amp. One thing that is disturbing is that it works as a an FM radio Jammer and severely scrambles the reception of my radio in the same room. Perhaps it could be dealt with if I soldered some small pF caps across the speaker outputs. When and if I open the case I will probably see if I can find room for some reservoir caps as well.
  Reply With Quote
Old 8th April 2013, 10:28 PM   #10
diyAudio Member
 
radiosmuck's Avatar
 
Join Date: Jul 2012
Location: Montreal
Quote:
Originally Posted by morglo View Post
One thing that is disturbing is that it works as a an FM radio Jammer and severely scrambles the reception of my radio in the same room. Perhaps it could be dealt with if I soldered some small pF caps across the speaker outputs. When and if I open the case I will probably see if I can find room for some reservoir caps as well.
I have 2 of the SML-SA-S1 units and a cheaper Lepai 2020A+ all using the same chip. I could not get any sort of FM reception just like you. I tried adding ferrite beads, changing power supplies, adding a isolation transformer to no avail.
Perhaps this problem is known, I seem to remember that they were advertised as being good for connecting to digital components.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Topping TP-20 Mk2 or SMSL SA-S1? kin0kin Class D 4 6th February 2012 03:39 PM
SMSL SA-36 funnies Psychobiker Chip Amps 1 7th January 2012 02:18 PM
Low distortion & noise digitally controlled volume chip abraxalito Analog Line Level 6 13th August 2011 01:14 AM
Which T-Amp? SMSL SA-S3 or Topping TP21? TylerDurden Class D 1 17th July 2011 02:42 PM
Help me regarding very low Supply Ripple output noise DC volume control unit electronist Parts 0 31st December 2003 09:29 AM


New To Site? Need Help?

All times are GMT. The time now is 02:09 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2