kicker 750.1 Green light no sound - diyAudio
Go Back   Home > Forums > Amplifiers > Class D

Class D Switching Power Amplifiers and Power D/A conversion

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 2nd February 2013, 04:42 PM   #1
diyAudio Member
 
Join Date: May 2011
Default kicker 750.1 Green light no sound

Can anyone help me try to figure out why I have no sound from my kicker amp even though the green light is solid. I have called kicker and they no longer provide schematics and I don't really know what to test. I have eliminated the board that contains the gain and all that by taking it out of a good 750.1 I also know it's not anything related to the wiring in the car as I hooked a different amp up in the same spot and it works. I know it's somewhere on the board but no tell tell burnt components.
  Reply With Quote
Old 4th February 2013, 01:46 PM   #2
diyAudio Member
 
nigelwright7557's Avatar
 
Join Date: Apr 2008
Location: Carlisle, England
First port of call is the output transistors, check for shorts D-S.
  Reply With Quote
Old 5th February 2013, 02:39 AM   #3
diyAudio Member
 
Join Date: May 2011
Thank you for your time I do apologize as it appears my second post with what I have tested did no go through. I will try this again though. I checked all those before with good results I checked the preamp board with a 12v result it appears that the signal dies in a component under the preamp board but I am unsure of what to look for in that region.
  Reply With Quote
Old 5th February 2013, 02:42 AM   #4
diyAudio Member
 
Join Date: May 2011
The last bit of life it displayed the woofer started popping wildly even with the stereo turn down and then one last pop and it was over. It has never made a sound since that last pop.
  Reply With Quote
Old 6th February 2013, 10:59 PM   #5
diyAudio Member
 
Join Date: May 2011
I tested the LM361N chip today here are the results:
12.1 volts dc in
pin
1 12.06 V
2 0
3 -4.016 V
4 0
5 0
6 -12.01
7 0
8 3.288
9 3.288
10 0
11 3.268
12 -2.182
13 3.019
14 3.289

can anyone verify these as correct or is this the chip i need to replace?
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
modding a Kicker ZX-750 to be 1 ohm stable? mat3833 Car Audio 0 20th January 2013 01:43 AM
help zx 750.1 kicker jeremy s Power Supplies 1 28th May 2012 02:59 AM
Kicker 750.1 mike49504 Car Audio 6 15th May 2012 11:15 AM
Kicker 750.1 mike49504 Car Audio 9 19th February 2012 12:50 PM
Kicker ZX750.1 Powers Up (green Light) No Sound bigpun4fubu Car Audio 43 13th November 2011 11:51 PM


New To Site? Need Help?

All times are GMT. The time now is 07:30 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2