TDA8950J hiss noise - diyAudio
Go Back   Home > Forums > Amplifiers > Class D

Class D Switching Power Amplifiers and Power D/A conversion

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 21st January 2013, 04:18 PM   #1
diyAudio Member
 
Join Date: Jul 2012
Post TDA8950J hiss noise

Dear friends:

I had done an amplifier using TDA8950 ,+/-16vDc rail to rail power supply . Soldered on PCB using the application circuit provided on datasheet.



But the problem is at the output the resistor 10ohm tesitor heats up ,and the sound on the woofer has more hissing ,then the music.

Tell me what may be the problem.

thanks
  Reply With Quote
Old 21st January 2013, 11:15 PM   #2
diyAudio Member
 
nigelwright7557's Avatar
 
Join Date: Apr 2008
Location: Carlisle, England
What have you got as an output filter ?
__________________
PCBCAD50 software. http://www.murtonpikesystems.co.uk
  Reply With Quote
Old 22nd January 2013, 01:56 PM   #3
diyAudio Member
 
Join Date: Jul 2012
Earlier I had done this circuit for amplifier ,it was working fine. Now again I have done one more PCB[soldered in Gerenal purpose PCB] using this TDA8950 .

The circuit as in Attachment .
Please, see.
Attached Images
File Type: jpg tda.JPG (73.6 KB, 129 views)
  Reply With Quote
Old 8th May 2013, 01:40 AM   #4
diyAudio Member
 
Join Date: Feb 2013
Do you still need help with your problem?
  Reply With Quote
Old 8th May 2013, 03:14 AM   #5
DUG is offline DUG  Canada
diyAudio Member
 
Join Date: Jan 2003
Location: mississauga ontario canada
one of the CSN caps probably shorted.

my guess

__________________
Doug We are all learning...we can all help
"You can't stop the signal, Mal. Everything goes somewhere..."
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hiss(white noise) on tweeters and one midrange? pshdk Multi-Way 7 9th August 2012 07:15 PM
Phono EQ hiss/white noise!!! chanwoo Tubes / Valves 10 24th March 2010 09:59 AM
i get hiss noise when the treble is turn up on high?? prorms Solid State 1 7th April 2008 11:00 PM
Background Noise (Hiss) -- How to Trace jandrusor Solid State 5 25th March 2008 07:47 AM
Preamp hiss noise morfeas Tubes / Valves 10 17th June 2005 04:52 AM


New To Site? Need Help?

All times are GMT. The time now is 09:15 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2