diyAudio

diyAudio (http://www.diyaudio.com/forums/)
-   Class D (http://www.diyaudio.com/forums/class-d/)
-   -   mtx thunder elite 4001d thermal light on (http://www.diyaudio.com/forums/class-d/227632-mtx-thunder-elite-4001d-thermal-light.html)

robbysankar 12th January 2013 05:24 PM

mtx thunder elite 4001d thermal light on
 
hi all.i have a mtx thunder elite 4001d amp on the table with the thermal led on when powered up.
i have checked all the power supply fets and ouput fets all are ok.

any help will be much appreciated.
thank you

nigelwright7557 12th January 2013 10:09 PM

Is the heatsink getting hot ?

robbysankar 15th January 2013 01:10 PM

no there isn't any rail voltage hence no heat.thermal light comes on upon connecting remote there isn't any current draw....just need advice on where to start.

robbysankar 17th January 2013 06:02 PM

well tried contacting mtx for advice .....guess living in south america has its disadvantages.

Tekko 17th January 2013 06:38 PM

Sounds like the overheat protection circuit is active.

If it uses the same LED for dc protection, it may also have a blown channel output stage.

robbysankar 30th January 2013 05:15 PM

just need some advice on where to check exactly i pulled all the outputs and still no go

robbysankar 8th November 2013 06:23 PM

i decided to pick this one up again.can some one help me with a schematic.

robbysankar 8th November 2013 11:18 PM

ok i still get the thermal light when i apply the remote....here is the readings i have so for using the power ground as reference...

for the tl494
1-0.01
2-5v
3-0.02
4-4.39
5-1.5
6-3.45
7-0.03
8-13.49
9-0.06
10-0.03
11-13.76
12-13.76
13-5
14-5
15-5
16-0.01

there are two lm339 ics i can't determine what the board labels are but this one located toward the fan connection and one towards a +5volt regulator.

for the one towards the fan i get...
1-2.20
2-0.23
3-13.76
4-0.10
5-3.13
6-0.83
7-3.13
8-3.22
9-5.01
10-5.01
11-8.28
12-0.06
13-0.01
14-0.01

for the one next to the +5volt regulator i get...
1-0.21
2-1.53
3-13.75
4-1.56~2.11
5-1.73~2.12
6-1.7
7-0.53
8-2.51
9-0.05
10-0.11
11-1.57
12-0.01
13-3.58
14-0.05

i'm stumped as to why the thermal light comes on when the amp has basically room temperature.i currently have all the power supply mosfets out of the circuit by the way.

any help will be much appreciated thank you.

robbysankar 8th November 2013 11:19 PM

lm339 towards the fan connector(correction)

robbysankar 9th November 2013 01:01 PM

has anyone had this problem before?


All times are GMT. The time now is 05:44 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio


Content Relevant URLs by vBSEO 3.3.2