MY CLASS D AMP - Page 25 - diyAudio
Go Back   Home > Forums > Amplifiers > Class D

Class D Switching Power Amplifiers and Power D/A conversion

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 13th April 2013, 03:23 AM   #241
diyAudio Member
 
aman khalsa's Avatar
 
Join Date: Oct 2010
Location: punjab
I m using IRFP250...
  Reply With Quote
Old 13th April 2013, 05:09 AM   #242
manojtm is offline manojtm  India
diyAudio Member
 
manojtm's Avatar
 
Join Date: Aug 2008
Hi AMAN,

IRFP250N can handle up to +/-122V supply and do not connect 2R & 4R load. only for 8R load.

Regards
MANOJ
  Reply With Quote
Old 13th April 2013, 10:59 AM   #243
diyAudio Member
 
aman khalsa's Avatar
 
Join Date: Oct 2010
Location: punjab
Ok thank u sir.. with IRFP 260 can I drive 4 ohm 600w lord on +- 120v.
  Reply With Quote
Old 13th April 2013, 12:25 PM   #244
norazmi is offline norazmi  Malaysia
diyAudio Member
 
Join Date: Feb 2008
+- 120 vdc is more than 600w at 4 ohm load.
  Reply With Quote
Old 13th April 2013, 12:36 PM   #245
manojtm is offline manojtm  India
diyAudio Member
 
manojtm's Avatar
 
Join Date: Aug 2008
Hi Aman,

+/-120V you will get True RMS 1800W@4R load and use Speaker 4R/3600W for full drive
+/-71V you will get True RMS 600W@4R load

Regards
MANOJ

Last edited by manojtm; 13th April 2013 at 12:39 PM.
  Reply With Quote
Old 13th April 2013, 02:29 PM   #246
diyAudio Member
 
aman khalsa's Avatar
 
Join Date: Oct 2010
Location: punjab
Thank u sir.
  Reply With Quote
Old 13th April 2013, 06:11 PM   #247
akraj is offline akraj  Bangladesh
diyAudio Member
 
Join Date: Nov 2010
Hi Manoj:

For last few months I was experimenting on your aud600 ver1. Today mistakenly I gave .1uf cap and instantly 2k/2w resistor blown away. Replaced that and removed .1uf with 1uf cap.

But there is no audio even no grid. Replaced all ICs but no response. All relative voltage is okay, relay connects, no overload nothing unusual. Still no response.

How and what I can check? I don have oscilloscope. Please suggest.

Thanks
Raj
  Reply With Quote
Old 14th April 2013, 08:28 AM   #248
diyAudio Member
 
aman khalsa's Avatar
 
Join Date: Oct 2010
Location: punjab
Didi u chek 12vdc aux.??
  Reply With Quote
Old 14th April 2013, 10:06 AM   #249
akraj is offline akraj  Bangladesh
diyAudio Member
 
Join Date: Nov 2010
Yes, I checked. All relative voltage are okay.
  Reply With Quote
Old 14th April 2013, 11:24 AM   #250
manojtm is offline manojtm  India
diyAudio Member
 
manojtm's Avatar
 
Join Date: Aug 2008
Hi Raj,

May be your relay blown.check your relay contacts

Regards
MANOJ
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Leaving class A how to make this amp leave class A to AB when volume is increased? rhythmsandy Solid State 2 15th June 2013 07:02 AM
Contest: Linear Power Amp in a mint tin (class Aa, class AB, or class B) danielwritesbac Chip Amps 206 19th January 2013 08:52 PM
does class A amp feel more powerful with same ratings compared to class AB? rhythmsandy Solid State 7 10th December 2012 05:21 PM
Configuring an AB class amp to work in pure A class jrme Tubes / Valves 5 23rd February 2010 06:31 PM
Can a Class AB PP amp be said to be operating in Class A at low signal levels? ray_moth Tubes / Valves 19 23rd January 2009 07:52 PM


New To Site? Need Help?

All times are GMT. The time now is 03:16 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2