Fixing an amplifier based around a ST TDA7492P - diyAudio
Go Back   Home > Forums > Amplifiers > Class D

Class D Switching Power Amplifiers and Power D/A conversion

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 7th October 2012, 12:25 AM   #1
diyAudio Member
 
Join Date: Oct 2012
Default Fixing an amplifier based around a ST TDA7492P

Apologies for making my first post a request for help. I know a bit about electronics, but not much about amps. I saw that other people on this board had helped out with similar problems in the past.

I'm trying to fix a mini-system type amp. The basic problem is that sound comes out of the headphones, but not out of the speakers. The speaker amp is based around a ST TDA7492P. Since the sound comes out of the headphones OK, I think it's this circuit is the problem.

Here is a circuit diagram from the datasheet. This isn't the exact circuit diagram of the board I've got, but it seems to be pretty close from examining the board.

Click the image to open in full size.

I've used an oscilloscope on the input pins 22 and 23, and I can see what looks like sound, biased to 1.6V. What I see when I look on the output pins (e.g. 6 and 7) is very strange- it looks like a big low frequency square wave. The square wave has noise on it. I can get a picture of the trace if it helps.

I've checked the mute and standby inputs and they are both high.

Any idea what's wrong with my amp?
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help fixing a 3886 based Behringer Studio Monitor amp! sylk Chip Amps 16 2nd November 2012 07:51 AM
Help fixing Crown power amplifier BlackUnikorn Solid State 22 9th August 2012 06:14 PM
Help with fixing Starsound Jackslammer SSA-JS2080B amplifier Mote Car Audio 3 1st November 2010 10:35 AM
Need some help fixing my amplifier(Exposure XV) imperfectcircle Solid State 8 28th January 2007 04:02 PM
Need Help/Schematic Fixing Sunfire Signature Subwoofer Amplifier Creelove Subwoofers 1 2nd March 2004 08:01 PM


New To Site? Need Help?

All times are GMT. The time now is 03:33 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2