hf ringing after inductor on positive halfwave. - diyAudio
Go Back   Home > Forums > Amplifiers > Class D

Class D Switching Power Amplifiers and Power D/A conversion

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 6th October 2012, 02:32 PM   #1
diyAudio Member
 
Join Date: Oct 2010
Location: Canada
Default hf ringing after inductor on positive halfwave.

I am getting what appears to be 28mhz ringing on the output of my filter (28uh, 680nf). I have been searching threads and still not sure why i have ringing on the output but very little on the power stage. Just wondering if anyone has any suggestions on how to resolve this.


The yellow line is taken at the output terminals (after filter) and the blue line is taken btw the mosfets (before filter).
Attached Images
File Type: jpg 1.jpg (291.1 KB, 250 views)
File Type: jpg 2.jpg (328.8 KB, 222 views)
File Type: jpg 3.jpg (303.3 KB, 220 views)
File Type: jpg 4.jpg (301.3 KB, 222 views)
  Reply With Quote
Old 6th October 2012, 03:04 PM   #2
Salas is offline Salas  Greece
diyAudio Chief Moderator
 
Salas's Avatar
 
Join Date: Oct 2002
Location: Athens-Greece
Welcome to DIYA. Smaller images next time please. 1200X900 will do. I resized and attached for this time.
  Reply With Quote
Old 6th October 2012, 03:16 PM   #3
diyAudio Member
 
Join Date: Oct 2010
Location: Canada
ok will do, thanks.
  Reply With Quote
Old 7th October 2012, 02:36 PM   #4
diyAudio Member
 
darkfenriz's Avatar
 
Join Date: Jun 2004
Location: Warsaw
Hi

Good to see the measurement setup.
Such arrangement is not very good for measement of dozens of MHz signals, try reducing the are of a probe scope and ground tip to minimum.
A hint: I solder a piece of UTP directly to what I measure and connect the probe several centimeters away with ground tip twisted around the probe, that's be e.g. at switching node and most adjustent ground reference.
Secondly, can you show both signals at the same scale? Keep in mind that the LC filter may be out of any attentuation at 30MHz.
  Reply With Quote
Old 7th October 2012, 03:40 PM   #5
Pafi is offline Pafi  Hungary
diyAudio Member
 
Join Date: May 2004
Location: Budapest
Parasitic (parallel) capacitance of inductor, parasitic (series) inductance of capacitor.

On the first picture rise time seems to be 50 ns, but on the second 20 ns. I guess there is some problem with the measurements.

High amplitude square on one channel of the scope can disturb the sensitive other channel.

Ground loop.

Agilent Technical Forums : Noise problem with DSO1014a? ...
  Reply With Quote
Old 7th October 2012, 06:45 PM   #6
diyAudio Member
 
Join Date: Oct 2010
Location: Canada
honestly i wasn't being careful with the probes after a bunch of testing i was getting lazy :P. but i will try twisting the ground around the probe! and use a single ground point for both probes (as i usually do!). also when i only use one probe at the output terminals i also get the same waveform... i will try to post more pictures after dinner tonight. (maybe some schematics to make things easier)

not sure if its visible on these images but the power stage does have a slight ring maybe the same amplitude but its also inverted to the signal after the inductor.


this is my fourth board with the same components but new layout. last builds where ok with only a very very small ringing around 5mhz but nothing appeared at the output. noise was ok but not as good as my class b or a amps. also had a dc offset around 80mv with -+50v supply. after a lot of time designing this board i was sure this layout was much better :/
  Reply With Quote
Old 7th October 2012, 07:03 PM   #7
diyAudio Member
 
Join Date: Oct 2010
Location: Canada
i have a feeling its the lc filter and lack of attenuation at such frequencies...

i am posting pictures of the power stage pcb and schematics. the red circles are the snubbers and decoupling capacitors the blue line is the only trace that is on the other side of the board (the rest being a ground plane). also the toroid is a t106-2 laying flat on top of the ground plane. the filter cap is a cbb metal film cap at 680nf 600v. also the decoupling caps are 1206 format 100nf XR7 100v. the snubber caps are 1206 format 100pf NPO 1000v.

oh i also changed bootstrap diodes from mur120 to ES1D on this design....

using irf530n only for testing...
Attached Images
File Type: jpg Untitled.jpg (266.9 KB, 185 views)
File Type: jpg Untitled1.jpg (154.2 KB, 82 views)
File Type: jpg Untitled2.jpg (165.5 KB, 84 views)

Last edited by switchleg; 7th October 2012 at 07:24 PM. Reason: resized attachments :)
  Reply With Quote
Old 8th October 2012, 02:32 AM   #8
Eva is offline Eva  Spain
diyAudio Member
 
Eva's Avatar
 
Join Date: Oct 2003
Location: Near the sea
Send a message via MSN to Eva
The falling edge is slow because it's soft switched, it's inductor current what charges parasitic capacitance rather than the opposite FET turning on. This is what happens in the rising edge, and the high di/dt excites the 28Mhz resonance that is made of L and C elements spread through the power stage layout. Once the resonance starts, you get AC voltages even across ground tracks, and some energy is radiated too, so the resonance appears "everywhere" unless you use the proper measurement techniques (for example: direct ground to scope probe ring, without relying on the classic alligator clip ground lead, which acts as a receiving antenna).

The C usually comes from the FET dies themselves, drain to source capacitance (few dozen to few hundred pF, changes with Vd-s, should be considered at proper Vd-s), although other capacitances connected to this node can alter the main resonance. The L comes from series elements: PCB traces from FETs to supply capacitors and the series inductance of these parts (in the order of a few dozen nH). The R is low enough to get an underdamped system. Personally I prefer to shift these resonances as high as possible in frequency because copper is more resistive at 100Mhz than at 30Mhz, getting more self damping to start with. Also, the snubbers needed to damp lower frequencies waste more power.

Things to do to improve it:
- Get good switching timing, the two halves of the output stage have not equal delays or dead times, this is important to keep good audio signal integrity.
- Try to move up the 28Mhz resonance by reducing layout and component lead inductances. It usually comes at ~1nH per mm of lead length/spacing for capacitors and transistor packages. Use ground plane, this reduces the ~1nH per mm of "unshielded" PCB tracks to much less, and makes tracks more lossy and leass inductive at RF.
- Use snubbers to damp the resonance. The right combination of C, R and parasitic L, just tuned to the main resonance, is what does the trick best. Fr=1/(2*pi*sqr(L*C))
__________________
I use to feel like the small child in The Emperor's New Clothes tale

Last edited by Eva; 8th October 2012 at 02:39 AM.
  Reply With Quote
Old 8th October 2012, 03:42 AM   #9
gootee is offline gootee  United States
diyAudio Member
 
Join Date: Nov 2006
Location: Indiana
Blog Entries: 1
Here is a practical procedure for finding the optimal R for the snubber you need, and the C to go with it:

paralleling film caps with electrolytic caps
  Reply With Quote
Old 8th October 2012, 04:38 AM   #10
diyAudio Member
 
Join Date: Oct 2010
Location: Canada
well the majority of the board is covered with a ground plane on the other side not shown(including the power stage and gate driver). with the 1nh per mm is starting to make sense if i add up the length of all the leads coming off both fets + the trace btw the two. also i wrote down the wrong frequency, the current ringing is at 35mhz (28ns). if i can manage to shorten the leads on the fets (and use better fets with lower COSS) i might be able to get upto 50mhz or so. then the only other option i have is tune the snubber to the ringing frequency and hope for the best. correct?
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Tapped HF inductor: where to get? Stabby Parts 0 20th April 2011 11:38 PM
Ringing on class d output inductor. nigelwright7557 Class D 36 25th February 2011 07:49 PM
Separate DACs for each halfwave ? Bernhard Digital Source 94 20th December 2006 06:06 AM
Cure for HF oscillation on positive cycles only RichardJones Pass Labs 4 27th June 2002 12:20 AM


New To Site? Need Help?

All times are GMT. The time now is 12:22 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2