diyAudio

diyAudio (http://www.diyaudio.com/forums/)
-   Class D (http://www.diyaudio.com/forums/class-d/)
-   -   Lepai LP-2020A+ Balance Problem (http://www.diyaudio.com/forums/class-d/217545-lepai-lp-2020a-balance-problem.html)

Nightcry7 8th August 2012 01:12 AM

Lepai LP-2020A+ Balance Problem
 
So I just got a Lepai LP-2020A+ and sometimes I seem to have a balance problem. Sometime the right channel is quieter. I have testing it with several speakers and have the same problem. Any ideas?

MarioRestucci 8th August 2012 07:16 PM

Quote:

Originally Posted by Nightcry7 (Post 3118524)
So I just got a Lepai LP-2020A+ and sometimes I seem to have a balance problem. Sometime the right channel is quieter. I have testing it with several speakers and have the same problem. Any ideas?

Defective balance trimmer? maybe defective IC?
can be anything

Lucywy 14th September 2012 09:41 AM

I think it is the defective IC.Get a change as this product is in low price

Bare 14th September 2012 04:16 PM

Look here for info on this amp. Amplifier:Lepai T Amp - diyAudio
Personal opinion? Disable ALL the tone circuits ( these are of garbage quality) and add in a new Pot for volume control IF you need one.
That, and the mods suggested above will give you a surprisingly good amplifier.


All times are GMT. The time now is 03:03 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio


Content Relevant URLs by vBSEO 3.3.2