Go Back   Home > Forums > Amplifiers > Class D

Class D Switching Power Amplifiers and Power D/A conversion

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 5th June 2012, 08:28 PM   #1
diyAudio Member
 
KyleinCowichan's Avatar
 
Join Date: Dec 2010
Location: Cowichan Bay, BC
Default Hifimediy T1-M Impressions?

Hello,

I am considering a Hifimediy T1-M. Does anyone have any experience with this amp? It looks like there is a new variation available. It's going to power some high efficiency speakers so I am not worried about cranking the maximum watts out of the chip.

Any thoughts would be appreciated!

Kyle
  Reply With Quote
Old 5th June 2012, 08:33 PM   #2
von Ah is offline von Ah  United States
diyAudio Member
 
von Ah's Avatar
 
Join Date: Feb 2008
Location: Maryland, USA
I am also interested in others' experiences with this amp. It may be part of my next amp project. Thanks!
  Reply With Quote
Old 6th June 2012, 12:34 PM   #3
redkid is offline redkid  United States
diyAudio Member
 
Join Date: Jan 2009
I have had the 1st edition of the Hifimediy T1-M running for at least 6 months. At 1st the sound was not that impressive, but like most Tripath chips ( I have about 1 dozen different amps, Sure, Helder, Lepai ) it took many hours playing before it "opened up".
It has good bottom end, highs are clear, mid-range is just plain. Not as good as some amps,but at least its not over the top. So I would say fairly well balanced sound.
Well constructed, runs cool (at 19V). The pot is cheap, but so is the amp!
I am not disappointed for the price.
  Reply With Quote
Old 6th June 2012, 02:21 PM   #4
diyAudio Member
 
Join Date: Mar 2009
I have had the T1 board for a couple of weeks now and im not that impressed with it treble is harsh bass a bit lacking. I think my 41hz amp 6 is better and nearly as powerfull. The T1 board does not produce the power that is stated i dont think so anyway i have to wind the pot three quaters of the way round to get it loud
  Reply With Quote
Old 6th June 2012, 04:06 PM   #5
diyAudio Member
 
KyleinCowichan's Avatar
 
Join Date: Dec 2010
Location: Cowichan Bay, BC
Hi Bull,

How many volts were you feeding it and what was it hooked up to? I am going to use it with a pair of EL70s in a Planet 10 enclosure. I don't need a huge amount of power.

KM
  Reply With Quote
Old 6th June 2012, 05:13 PM   #6
diyAudio Member
 
Join Date: Mar 2009
Quote:
Originally Posted by KyleinCowichan View Post
Hi Bull,

How many volts were you feeding it and what was it hooked up to? I am going to use it with a pair of EL70s in a Planet 10 enclosure. I don't need a huge amount of power.

KM
Im runing on 24v 13 amp and useing mission m74 speakers and a modified marantz cd67 se
  Reply With Quote
Old 7th June 2012, 01:07 PM   #7
redkid is offline redkid  United States
diyAudio Member
 
Join Date: Jan 2009
I think bull is confusing the T1 with the T1-M,,,see his post about T1 sounds harsh,,,

I have the T1-M and for the money its a great little amp.
I only wish I could run higher than 24V
  Reply With Quote
Old 7th June 2012, 04:53 PM   #8
diyAudio Member
 
Join Date: Mar 2009
Quote:
Originally Posted by redkid View Post
I think bull is confusing the T1 with the T1-M,,,see his post about T1 sounds harsh,,,

I have the T1-M and for the money its a great little amp.
I only wish I could run higher than 24V
Yes sorry mine is the t1 but still not impresed with the sound i think my 41 hz amp blows it away for detail top end mid range all round the 41hz amp is better
  Reply With Quote
Old 8th June 2012, 08:19 AM   #9
zog666 is offline zog666  Australia
diyAudio Member
 
Join Date: May 2009
I have a few T1-M and I like them.

Not as powerful as my T2 or other Class D amps, but at low volumes they sound great for the price point.

With a 50W 20V SMPS they run cool and don't pull much electricity, great for my tiny bedroom system for listening while I read in bed.
__________________
audio project blog http://www.minirig.org.au/
  Reply With Quote
Old 17th June 2012, 07:50 PM   #10
diyAudio Member
 
Join Date: Sep 2006
Quote:
Originally Posted by redkid View Post
I have had the 1st edition of the Hifimediy T1-M running for at least 6 months. At 1st the sound was not that impressive, but like most Tripath chips ( I have about 1 dozen different amps, Sure, Helder, Lepai ) it took many hours playing before it "opened up".
It has good bottom end, highs are clear, mid-range is just plain. Not as good as some amps,but at least its not over the top. So I would say fairly well balanced sound.
Well constructed, runs cool (at 19V). The pot is cheap, but so is the amp!
I am not disappointed for the price.
Can you compare it with the others, speacially at low-voltage use?

I plan on using it on a car SQ setup.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hifimediy T1 low output with Iphone Stumbo Class D 1 8th December 2012 05:36 AM
HIFIMEDIY T1 SOUNDS HARSH AND BRIGHT bull041161 Class D 39 21st September 2012 03:03 AM
HIFIMEDIY T1 WIREING INSTRUCTIONS HELP bull041161 Class D 5 17th May 2012 01:54 PM
Hifimediy T1 DC Offset problem activexp Class D 1 20th March 2012 12:18 PM
Need help setting up new HIFIMEDIY T1 n8huntsman Class D 2 10th February 2012 04:21 AM


New To Site? Need Help?

All times are GMT. The time now is 07:38 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2