Help with Lepai LP-2020a+ - diyAudio
Go Back   Home > Forums > Amplifiers > Class D

Class D Switching Power Amplifiers and Power D/A conversion

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 16th February 2012, 10:03 PM   #1
diyAudio Member
 
Join Date: Feb 2012
Default Help with Lepai LP-2020a+

Hello I'm new to the forum and I bought one of those Lepai 2020a+ amps and I got it to my mailbox today.When I was gonna test it I used a 12 V 5A power supply(wich I later found out was AC) and I connected it and you culd hear the relay switch on and off constantly and afther a while a capacitor practically blew up and left alot of smoke and liquid.I didn't understood why it happend,I was assuming it had to do with the power supply and then I found out it was a AC output so I opend up the amp and replaced the capacitor and added a diode to the power suppy and started it,and it seemd to work so I connected it to the speakers and the input but I get no signal out to the speakers.And I also bypassed the relay but without any sucess.Now I wounder if there is some other component that may be fried so is there any way to troubleshoot and find what component is failing? I am not very familiair to this board as I just got it.
Thanks alot
  Reply With Quote
Old 17th February 2012, 01:35 AM   #2
diyAudio Member
 
nigelwright7557's Avatar
 
Join Date: Apr 2008
Location: Carlisle, England
You have probably blown the chip as well.
__________________
PCBCAD50 software. http://www.murtonpikesystems.co.uk
  Reply With Quote
Old 17th February 2012, 04:36 AM   #3
diyAudio Member
 
Saturnus's Avatar
 
Join Date: Jun 2005
Location: Copenhagen, Denmark
Quote:
Originally Posted by nigelwright7557 View Post
You have probably blown the chip as well.
I'd be very surprised if this isn't case.
  Reply With Quote
Old 17th February 2012, 09:09 AM   #4
diyAudio Member
 
Join Date: Feb 2012
Quote:
Originally Posted by nigelwright7557 View Post
You have probably blown the chip as well.
Ahh I was thinking that too,I will order a new chip from ebay and replace it and see if that fixes it thanks
  Reply With Quote
Old 14th September 2012, 08:43 AM   #5
Lucywy is offline Lucywy  United Kingdom
diyAudio Member
 
Join Date: Sep 2012
Location: GZ
Yeal ,blown the chip ,I met the problem before.
  Reply With Quote
Old 14th September 2012, 03:24 PM   #6
Bare is offline Bare  Canada
diyAudio Member
 
Join Date: Dec 2001
Location: vancouver
Hmmm. Shorted out a speaker wire and blew a channel on mine.
Bought a replacement Lepai... not yet delivered tho. sigh.
Also bought a YuangJi
YJ TA2020 20W+20W Class D amplifier board | eBay
Which did arrive... after 2 weeks.
Frankly it's a Much! better circuit. (No box though) needing little if any 'Upgrading' unlike the Lepai which needs a Lot (most) of it's parts replaced.
PS: Ta2020 chips are available for $5 with free shipping... IF you want to bother with the Lepai ressurection ? Removing the chip from the PCB's through plated holes without ruining the pcb is.. not.. a trivial task

Last edited by Bare; 14th September 2012 at 03:27 PM.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Which TA2020 amp? Topping TP20, Amp-03, or Lepai LP-2020 nkx1 Chip Amps 36 31st December 2013 11:43 AM
SureTA-2024 Board integrated in Lepai LP-2020 - Quad Channel amp QT0815 Class D 3 13th February 2012 10:11 PM
Fun with Lepai, but looking for more jonkun227 Chip Amps 1 9th December 2011 04:36 PM
Lepai LP-2020 mod to include sub out rziebro Class D 1 12th February 2011 03:01 PM
Are these two Lepai amps actually the same? goodgnus Class D 4 14th October 2009 01:28 AM


New To Site? Need Help?

All times are GMT. The time now is 05:44 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2