diyAudio

diyAudio (http://www.diyaudio.com/forums/)
-   Class D (http://www.diyaudio.com/forums/class-d/)
-   -   Lepai TA2020 Clicking Sound (http://www.diyaudio.com/forums/class-d/206536-lepai-ta2020-clicking-sound.html)

papayoyo 12th February 2012 05:37 AM

Lepai TA2020 Clicking Sound
 
Sorry if this has been answered before, I did a search but couldn't find an answer.

My new Lepai TA2020+ just arrived...

eBay - The UK's Online Marketplace

Pretty good deal I thought at £12.99 delivered with PSU.

Paired up with a set of £15 Acoustic Solutions book shelf speakers, a good value system for £28 I thought.

And indeed the sound is pretty amazing for the money, but as soon as I switched it on there was an annoying continuous rapid clicking sound coming from it, especially the right channel. It seems to attenuate with loud volume music, but maybe the music is drowning it out?

Any ideas? Is this a common fault that I can fix by resoldering or changing a relay or capacitor or something?

Cheers.

Franfj 13th February 2012 12:03 PM

Get a good quality RCA cable, the one provided seems crappy, I have one like that and changing the RCA solved the problem.

But first try the amp without any input cable plugged, it shouldn't make any noise (or just a little high freq noise), if it shows the same sound probably is something wrong with the amplifier…

papayoyo 13th February 2012 12:39 PM

Thanks for the reply.

The clicking sound happens even with no lead plugged in. :(

Guess I'll have to open it up and have a look for dubious soldering.

Just thought this might me an issue that's raised it's head before.

nigelwright7557 19th February 2012 12:55 AM

Sounds like the class d chip is going into protect.
Could be blown, I would also check the output mosfets for shorts.

papayoyo 19th February 2012 02:49 AM

The amp still works pretty well and the sound is good. It's just this constant background clicking. So I doubt anything is completely blown. Will check the soldering for shorts. Could it be the power supply?

jjne 14th March 2012 02:50 AM

Weird. You and I could almost be the same person. Both in the UK, both bought lepais from eBay and paired with acoustic solutions speakers and both have seemingly the same feint, low-frequency click/buzz from the right channel :s

I am suspecting the PSU that came with the unit just now, possibly too high ripple voltage as the supply is causing a mains hum in another small, cheap amp bought at the same time. I'll post back if I work anything out :)

jjne 14th March 2012 08:31 PM

OK, I can confirm that the problem you're experiencing papayoyo is the power supply included with the amp you bought :)

I bought the same amp from the same ebay seller, and have just tried the amp with an alternate power supply and, guess what, no clicking :D

So nothing wrong with your unit I'd wager.

orix102 27th March 2012 04:03 PM

Sugden AU41C MM and AU41P Pre Power
 
Hi all

Not sure if this is right thread. Recently I encountered problem with my
Sugden AU41C MM and AU41P pre power amp.

I was trying to biwire my Quad 11L speaker. On start up, there is a ticking sound coming from the power amp with no output coming out from the right speaker. Already swapped it L/R..no problem with speaker I guess because there was sound coming out if using L channel connection.. Ticking sounds continue thereafter...


sounds like ..tick..tick..<pause>..tick..tick..<pause>

What could be the problem? Thanks...

trunkline 27th March 2012 06:38 PM

It's really 2020A+ version ? Because according to wiki, the 2020A+ should have the bypass switch button and the photos of the seller does not appear.

Amplifier:Lepai T Amp - diyAudio

jjne 28th March 2012 10:52 AM

No -- these are 2020B with 2020A+ written on the top.


All times are GMT. The time now is 11:57 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio


Content Relevant URLs by vBSEO 3.3.2