Please help me on JL E1400D Amp - diyAudio
Go Back   Home > Forums > Amplifiers > Class D

Class D Switching Power Amplifiers and Power D/A conversion

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 26th December 2011, 04:46 PM   #1
diyAudio Member
 
Join Date: Jul 2011
Default Please help me on JL E1400D Amp

HI Again i have a used JL E1400D amp i would like to try to fix. I have power on lights, the protect light is off and idle with out getting hot, but very very low sound coming out with gain 1/2 way up. so anybody run into this problem please respond so i can try to fix this amp Thank you
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
JL AMP E1400D powers up but heardly no sound superjoey01 Class D 2 26th December 2011 03:40 AM
JL 13W7AE car subwoofer in JL Gotham 213 Vs B&W ASW 855 muddasirwaheedmalik Subwoofers 9 9th September 2011 04:34 AM
JL E1400D Repair or Trouble shooting superjoey01 Class D 0 12th July 2011 03:05 PM
Can I run a 10 inch JL audio and a 12 inch JL audio off same amp ash4kel Car Audio 2 8th April 2011 02:12 AM
JL audio E1400D mike49504 Car Audio 19 26th June 2010 09:23 AM


New To Site? Need Help?

All times are GMT. The time now is 04:39 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2