amp repair, need help. video inside - diyAudio
Go Back   Home > Forums > Amplifiers > Class D

Class D Switching Power Amplifiers and Power D/A conversion

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 9th November 2011, 01:56 AM   #1
diyAudio Member
 
Join Date: Nov 2011
Default amp repair, need help. video inside

ok, with power, the amp is drawing too much current and some of the chips are getting very hot, i put some things back in the wrong spots. be easy on me, its my first amp repair. heres the video. please watch the whole thing and let me know what you think. thanks. need any other info, please ask.

blown amp - YouTube

Last edited by firebirdjimbo; 9th November 2011 at 02:24 AM.
  Reply With Quote
Old 9th November 2011, 03:44 PM   #2
diyAudio Member
 
Join Date: Nov 2011
UPDATE. ok, there were 4 TIP35c's so the 35c's went on one side, and the 36c's go on the other, can someone tell me which side goes where?
  Reply With Quote
Old 9th November 2011, 08:30 PM   #3
diyAudio Member
 
nigelwright7557's Avatar
 
Join Date: Apr 2008
Location: Carlisle, England
I would check the output mosfets first and replace where necasary.
If the chips still get hot then one or more might have fried.

Had a similar problem on 2092 based system and the mosfets frying took out the 2092 too. Replaced both and teh amp was fine.
__________________
PCBCAD50 software. http://www.murtonpikesystems.co.uk
  Reply With Quote
Old 10th November 2011, 10:09 PM   #4
diyAudio Member
 
Join Date: Nov 2011
Quote:
Originally Posted by nigelwright7557 View Post
I would check the output mosfets first and replace where necasary.
If the chips still get hot then one or more might have fried.

Had a similar problem on 2092 based system and the mosfets frying took out the 2092 too. Replaced both and teh amp was fine.
are you talking about the N0506 mosfets? or the TIP35/36c's?
  Reply With Quote
Old 10th November 2011, 10:23 PM   #5
diyAudio Member
 
nigelwright7557's Avatar
 
Join Date: Apr 2008
Location: Carlisle, England
Quote:
Originally Posted by firebirdjimbo View Post
are you talking about the N0506 mosfets? or the TIP35/36c's?
I would check both.
__________________
PCBCAD50 software. http://www.murtonpikesystems.co.uk
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Where to place amp: Inside a common cab or inside speakers? goldyrathore Chip Amps 3 3rd September 2010 12:39 PM
Anyone dabble in video monitor repair? I need help... ppia600 Everything Else 4 3rd April 2010 05:20 PM
foam surround repair video? unpredictable Multi-Way 6 9th April 2009 02:58 AM
Anyone ever repair the smps inside an Alpine V-Drive head unit? turbo_slug Car Audio 1 18th March 2008 08:42 PM


New To Site? Need Help?

All times are GMT. The time now is 01:59 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2