bad Xtant 1001/x amp? - diyAudio
Go Back   Home > Forums > Amplifiers > Class D

Class D Switching Power Amplifiers and Power D/A conversion

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 10th October 2011, 01:52 AM   #1
diyAudio Member
 
Join Date: Oct 2011
Default bad Xtant 1001/x amp?

I believe it's the Xtamt 1001/x amp. My config is a Xtant 604x running my highs, and the 1001/x running my JL Audio 13W7.

Before the sub went totally out, the sub (lows) was fading in and out when I listened to a cd with heavy bass. That happened for about for about a month. I then hit a pothole, and the sub went out altogether.

I had a local mobile audio tech take a look, he just deemed the amp as bad. I don't have to much faith in his findings, since he only used an old fashion volt tester. The one that lights up red or green. Sorry I don't know the correct name for the device.

The tech did say the amp was getting power and the ground was good. He also noticed the a yellow light on the amp came on from time to time for a nano second.

Since the amp is over 10 years old, calling Xtant was a joke. I don't know anybody the services old amps in Philly. I don't have 1K to buy a new one right now. Any/all suggestions are welcomed.
  Reply With Quote
Old 12th November 2011, 01:57 PM   #2
cabron is offline cabron  United States
diyAudio Member
 
Join Date: Apr 2010
Location: central coast CA
I have an absolutely perfect Xtant x1001 I will let you have for $400 shipped!
Also have a 1001dx I'll let you have for considerable less.
Let me know.
  Reply With Quote
Old 12th November 2011, 02:11 PM   #3
diyAudio Member
 
Join Date: Sep 2010
^^ Funny nick :P
  Reply With Quote
Old 12th November 2011, 06:15 PM   #4
diyAudio Member
 
Join Date: Oct 2011
Thanks, but I have replaced the defective amp. I have found a place in PA, that will fix the amp.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
WTB: BEL 1001 mk2-5 amp wokdwok Swap Meet 0 7th March 2011 02:08 PM
Xtant 1001 D mike49504 Car Audio 33 24th November 2010 11:05 PM
PS 1, SCPH-1001 & controller, for parts, $5 pjanda1 Swap Meet 0 17th March 2009 10:14 PM
xtant A2002 amp burnt? hbch Car Audio 1 12th November 2008 11:52 PM
xtant a2002 amp genes66 Car Audio 3 26th February 2008 08:48 PM


New To Site? Need Help?

All times are GMT. The time now is 08:18 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2