lepai ta2020(b) no sound when reching high volume - diyAudio
Go Back   Home > Forums > Amplifiers > Class D

Class D Switching Power Amplifiers and Power D/A conversion

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 2nd October 2011, 03:07 PM   #1
diyAudio Member
 
Join Date: Jan 2011
Default lepai ta2020(b) no sound when reching high volume

i have a lepai 2020b - 8aa battaries
it was working well for 4 months
now when i turn the volume up the amp stops and ther is no sound,the blue led is flashing (very week),and the voltage is 4-5v insted of 11-12v(new battaries)

2 make it work again i need 2 turn it off for 20 sec and turn the volume on low.

the only mod i did is 2 take the realy out.

if someone can help me fix it that will be great
  Reply With Quote
Old 2nd October 2011, 08:34 PM   #2
diyAudio Member
 
nigelwright7557's Avatar
 
Join Date: Apr 2008
Location: Carlisle, England
Could be your batteries are starting to discharge ?

A lesser charge in the battery would increase its internal impedance and upset the amplifier.
__________________
PCBCAD50 software. http://www.murtonpikesystems.co.uk
  Reply With Quote
Old 2nd October 2011, 08:54 PM   #3
diyAudio Member
 
Join Date: Jan 2011
Quote:
Originally Posted by moshemft View Post
i have a lepai 2020b - 8aa battaries....
...11-12v(new battaries).....
new duracell battaries,
and when the battaries are week it dos stop but u just need to turn the volume down to get the amp working...
in my case it needs a full power off for 20 sec until it can start again even with new battaries and then again-if u turn the volume up(buth mp3 and amp) the amp frezes causing the led 2 flash very low light
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Lepai T-Amp with TA2020 Fin Class D 1930 12th September 2014 02:06 PM
No sound from Lepai TA2020, no current draw SecretChimp Class D 2 14th September 2011 08:02 PM
No sound from Lepai / TA2020 ggaahh Class D 2 12th June 2011 02:16 PM
Lepai TA2020 westsounds Class D 5 3rd January 2010 08:03 PM


New To Site? Need Help?

All times are GMT. The time now is 04:07 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2